[Activated!] Sleeping Part Behavior Improvements

Sleeping parts are still an issue for a lot of my use cases.

Here is a sign hung with 2 RopeConstraint’s to a anchored part. The sign also contains a AlignPosition and AlignOrientation with relatively weak force to keep it from jiggling constantly.

Here’s the the sign model. I noticed that the sleeping isn’t quite as bad in a blank place with just a baseplate, but it still happens frequently.

sign.rbxm (13.2 KB)

2 Likes

Working on a little project, using AlignPosition and AlignOrientation to position weapons in a characters hands. Weapons are massless and no collide.

The weapons are regularly falling asleep like this when they should be constantly positioning themselves towards the characters hands. I could manually fix them whenever the player moves but I don’t think the sleeping behavior is supposed to work this way.

Edit: This problem was fixed!

6 Likes

The problem I showed in my previous post was fixed, but as of a few days ago its started happening again. BodyVelocity getting applied, but the train refuses to move, unless I select a tool.

1 Like

A similar issue was happening to me a few days ago, super bizarre. It disappeared and came back just now. The soldiers in my game refuse to move. Their networkowner is the server.

I SetNetworkOwner to a Player(Its nil to prevent exploits) and that fixed their physics. I set it back and they kept working. Please fix roblox

@TheModsterRB, @Alkan

Could both of you please message me with more details and an rbxl file that reproduces your issues?

Almost positive I wanted to make a Tipping point game but wasn’t able to. This feature would probably make that style game so much easier!

Us too, our buses have stopped moving at random, sometimes it will move (like normal), and sometimes will be stuck.

I’m having problems with custom NPCs not playing animations, which I’m assuming is because the parts are “sleeping”?

They only render the animations when I walk away from the NPC (changing the network ownership), or changing the transparency or other properties of the parts inside the NPC.

I have messed around trying to do a tipping point game, or at least the sliding part, I ran into an issue with constraints with how I was moving it, as I was using body velocity to ensure the coins were moving with it but it would struggle to move after so many coins built up. If you could get it working I would love to see it in action as I am kind of stuck on how I would go around doing it.

I don’t think this is intended behavior. There’s no scripting in this either, just unanchored MeshParts. Sleeping Parts related i think. Studio Play mode

3 Likes

My game is still having issues like this.


In my game people are getting confused because once they spawn in, they are unable to fly or drive because the parts are asleep.

These conveyors work via velocity.

Wait now that I have more experience I think I get it

Is there any way to activate this in-game?

It is already live. You don’t have to do anything since it’s out of beta and a part of the game now :slight_smile:

I’ve been having issues using HingeConstraints where the parts do not wake up immediately and the physics just stop.

As seen in this video, when updating the velocity the part refuses to move unless you attempt to change the velocity once the part has woken up.

Try it for yourself.

workspace.Model.Center.Velocity = Vector3.new(10,10,10)

BrokenHingeConstraints.rbxl (19.1 KB)

2 Likes

I think this update broke my game. Due to sheer amount of objects in my game that need to be moved and/or rotate on demand (320 staircases, usually 5 moving at a time), I implemented manual anchoring system. I am using AlignPosition and AlignOrientation and enable/disable these on the fly, while anchoring stationary stairs.

Recently the game broke, and stairs started to drop or fling randomly in half of the cases. The game is completely broken now. Is there any way to fall back to the previous system? It took me ages to develop stair moving functions.

Please see video and observe orange stairs. That did not happen before, and I made no updates for two months.

I have a motorcycle that will not move with a VectorForce until I wiggle the entire model.
Once the model comes to rest entirely, it will fall asleep again until I force it to wake up.

The VectorForce does not wake it up.

Notice how the VectorForce is moving in the clip but the bike does not? After turning side to side, this forces the assembly to wake up, allowing the VectorForce to work.

2 Likes

I’ve tried to make the following physics based game for about 5 years now.
First 3 times I gave up because the physics would mess up.

Tried it again recently and pretty much everything has gone smoothly.

I don’t know if it’s because of this feature but thanks for improving the sleeping behaviour. It seems to have made one of my long time passion projects possible.

1 Like

Hello!
I’d like to request that anyone running into bugs to please report them in the Engine Bugs section of the forum, and please follow the post guide. This makes it much easier to track and follow up to each independently. If you are pretty sure it’s a bug related to sleep, feel free to tag me in the post to get my attention.
I’ve already followed up with the latest replies directly, and should mention we there is a known bug related to the posts from @AbstractAlex and @duke_tylerjone being worked on now.

We will be locking this thread.

3 Likes