All my plugins have disappeared

I installed a plugin from the catalog using the new install feature when I had teamcreate open, and all my plugins (except for a manually installed one) have disappeared. They seem to still all exist under the InstalledPlugins folder, each in their own folder with a Plugin.rbxm file inside , but they aren’t in the Plugins folder anymore. Closing/reopening studio has no effect. Can anyone help?

14 Likes

Have you tried reinstalling them? And there are no plugins inside the plugin folder? It’s just empty?

3 Likes

I can reinstall them but theres a LOT of them and reinstalling them all would be a pain, on top of that it’s concerning that my plugins can just all disappear so this problem should definitely be addressed.

There is only one plugin in the Plugins folder, the manually installed one

6 Likes

What software are you running / what are your system specs. I’ve been experiencing a similar issue on my MacBook running MacOS Catalina

4 Likes

I can second this, however, I have this same issue whenever studio updates. What happens is that I have to log back in again, and when I open a game, only my manually installed plugins appear. It’s a inconvenience for me and I just reinstall what I need most of the time.

4 Likes

This happens to me a lot. My plugins will be wiped but will remain in my inventory under plugins. I have to re-install which is a pain, but is the only solution I found for the problem at hand.

6 Likes

Device: Mac
Software: Up To Date

So for some reason since Studio updated on my Mac, the plugin tab does NOT display any of my plugins.

I am logged into the correct account. I don’t know why but when Studio updated like 3 days ago, I got on after the update and realized that my plugins are not there, so I refreshed (got out of the file and back in) and still not there. Very weird, I think this only occurs on MAC and not PC because everyone I know that has a PC, doesn’t have any issues.

This if very odd, here is a gif of the situation:

I have already tried to restart my computer as well as reinstalling. None of which fix the problem. There has been many problems with Studio and Mac. I don’t know why but it seems every here and then, there appears to be a bug that does not allow me to develop any thing on Studio.

9 Likes

Not sure if this has been resolved for you guys, but I just found a solution to the problem on my end. I’m also using Mac OS and every time I opened Roblox Studio my plugins would not be usable, i.e. not in the plugin bar, despite them being downloaded and fully up-to-date.

I found that when I looked through the “Plugins folder” located in studio it would take me to where the plugins were saved on my computer. There I found that the plugins were somehow jumbled in all sorts of weird ways, for example the “installed plugins” folder was duplicated and inside of itself, and other duplicates and disorganized codes were everywhere. In the end, once I sorted out the disarray most all my plugins returned to the plugin bar and were usable again.

I should also add that re-organizing the plugins is not a permanent fix, as the inevitably disappear again later. It will allow you to keep building without doing the uninstall-reinstall method every time though.

2 Likes

I have also just encountered this issue as of around the day before and I did not touch anything related to Roblox in my filesystem: they just inexplicably disappeared after I installed a plugin on two accounts using the toolbox. Why does Studio do this without any prompt? Don’t understand.

I have 7 copies of the InstalledPlugins folder that existed at the time of this post: 6 of which are under folders which have a UserId as the name of the folder, and one that’s in the Studio directory directly. I don’t know which is the true one that Roblox uses or why it’s set up like this.

So I went ahead and messed around with the plugins folder, of course I did. Literally nothing happened. I deleted all the UserId folders except for mine and then merged every single plugin folder between the top-level InstalledPlugins level and my own profile. Still, all my plugins are gone. That temporary fixed thus failed and I have to reinstall all my plugins.

What the heck? I literally did nothing before all this. My plugins just up and vanished and now I have to reinstall them? What is going on with Studio lately? It’s failing when I need it the most and this is bloody frustrating.

Note: Plugins on my other account are fine, it’s just this one where they refuse to work. They appear everywhere else except in Studio and in plugin management and in the toolbox, they’re marked as not installed. Their installation is just ignored. Reinstalling them works but I have so many to do that across.

2 Likes

My plugins have disappeared many of time haha. Try to click “update” (if the plugin has the option) or just click details and reinstall them all. I don’t think it comes back randomly. I’m 98% sure it’s because you’re using a mac. Sorry

1 Like

The thing is that all my plugins are still there but Studio itself in plugin management and the toolbox recognises them as not installed.

I am not using any Apple device of any sort, yet I experienced this issue. I had to go back and reinstall all my plugins because anything I tried to modify on my filesystem did not work.

Studio should not be whisking away my plugins, period. Clearly this is still a long running issue if the original report was made in March and I experience this in June: and I can’t even discern a cause of it, only when it starts happening. It needs to be investigated and stop happening completely.

Never had this issue before cloud plugins was introduced.

7 Likes

Just had this same issue seems to only happen when in a team create.

1 Like

Do you have plugins in your inventory when you installed them?

1 Like

Yeah. All my plugins are gone including the ones I made myself

1 Like

I started to have this problem today on Windows 10. If a open a new place all installed plugins appear on the tab, but on my old saved places only the default plugins appear. Reinstalling the plugins don’t fix the problem because they appear after the install, but if I close the place they’re gone again.

A temporary and very inconvenient solution that worked for me is to open the “Manage Plugins” page and disable and then enable the desired plugin again. This toggle makes the plugin show on the tab, but if you close the place, the plugins are gone again. You have to do it this every time you open the place.

A more risky solution (I’m saying risky because I don’t know how Roblox Studio handle it’s files internally) is to open Plugins Folder on Studio. This page should be empty. Go to the parent folder named Roblox and then go the folder with your used id. There you’ll find Installed Plugins. If you hunt down the .rbxm Plugin files with the plugin actual code and put them on the original Plugins Folder (the one you opened from Studio) it shows again for good on any place.

2 Likes

Sorry for the bump but I can also second. But I’m on Windows and all of my Plugins were Deleted after updating Roblox Studio. They’re not in my folder OR my Manager… I had A LOT of plugins, and this is a massive inconvenience. Please fix.

The same thing happened to me, but restarting Studio seemed to fix it.

Yeah, this has happened to me 2 times, they’re all gone, and I need to reinstall all of them.

Same issue. I think I need to re-install them all. Hope this gets fixed.

Adding on what I said, all the plugin folders are still there, and their names being the RBX ids. BUT, all their contents (the settings and the actual plugin itself) just got Thanos snapped.

1 Like