All my plugins have disappeared

It seems as this issue has come up once again, All my plugins that aren’t locally installed have uninstalled themself. I also looked at the plugins folder, and saw the same issue of missing contents, as @ShadowAlien98 had described.

This issue seems to occur inconsistently as well, through a little testing testing i wasn’t able to replicate this behavior again. I would like to note that I did enable “Enroll in Beta Channel” and enabled all beta features, if that can help with this issue. This bug is a very annoying time waster, and while not studio breaking, it has indeed messed with my development.

This happened a while back to me as well.

  • Device OS: Windows 10 Home
  • Software Version: Current Version (10.0.19042 Build 19042 as of writing this)
  • Software Type: x64-based PC
  • Installed/Total Physical Memory: 16.0 GB
  • Total Virtual Memory: 18.3 GB
1 Like

Happened to me too recently. Had to manually install my plugins by putting the rbxm file in my plugins folder.
OS: Windows 10 Home, 64-bit, Version 20H2 (OS Build 19042.867)
Hardware: 16 GB DDR4 ram, AMD Ryzen 3600, Nvidia GTX 970

This just happened to me and every time I reinstall them they disappear from the manage plugins menu on studio start up.

How do I fix this?

Same problem happened to me. I am getting so close to quitting devolopment. MacOS has way too many bugs.

Just had this happen to me, its a big issue…

When I try to reinstall the plugin, it removes the last one I installed and only lets me have one at a time. Not sure what is up with that

And for the one that is installed, it doesn’t even show up in the toolbar.

2 Likes

I just had this happen to me on a Windows 10 Build 19042.

Was installing a plugin for the first time on a freshly reinstalled windows build and all of my plugins besides the one I have installed disappeared.

RobloxStudioBeta_l8CeK1ZCk2
RobloxStudioBeta_VMRn3B4a3r

Edit: Went and reinstalled every plugin I had installed before hand and this is the plugin that’s giving me issues: Color Adjust - Roblox

1 Like

I just had the same thing happenedto me. I installed a plugin called ‘Local File Importer’ and it turned out to uninstall my other dozen or so plugins.

Big issue for me, I’ve no idea how to fix this.

Just had it happen to me, twice. After installing one plugin, all of my plugins disappeared, but then later reappeared, and then when I installed another plugin, all of my plugins disappeared again.

Checking out new and old log files, it appears that installing plugins has messed up the cloud save of the plugins. New log files only show an attempt to load the latest plugin that I have installed, while the old log files show all plugins being loaded from the cloud. Is this an issue from this update?
https://devforum.roblox.com/t/installed-plugins-now-saved-in-cloud/340503/85

2 Likes

Same issue with plugins disappearing today after the latest studio update. I only have one single plugin. Manage Plugins only shows that one plugin. The only available plugin is my most recently installed one.

Yep, that’s why I’m backing my plugins up now…we can only hope this will be fixed soon.

This happened to me a few weeks ago. Luckily I don’t use plugins very much, so I’m just reinstalling them as I need them.

I don’t have any information on how it happened as I’m not sure exactly when it happened or what I did at the time.

This just happened to me for the first time. Though, I did not install a new plugin. They basically disappeared on their own after opening studio and system boot up. I will confirm that they still show up in the directory of which they have been installed.

1 Like

Actually, no. I have had this issue a few days ago where i needed to install a new plugin on my windows and all of a sudden all of my plugins were wiped. For me personally it did not matter too much as all of them were in my inventory so it basically resulted in a free/automatic cleanup. Note that at the time i was not in team create.

Today I discovered that I’ve spontaneously lost all my installed plugins again. The only ones left are ones that I’ve hand-installed to the Plugins folder, otherwise everything else in InstalledPlugins does not show up on my ribbon bar or plugin management window. Only my most recently installed plugin, fivefactor’s Interface Tools, shows up in plugin management.

I’m convinced that this is just a loading issue however as both my user InstalledPlugins folder (%localappdata%\Roblox\6809102\InstalledPlugins) and my general InstalledPlugins folder (%localappdata%\Roblox\InstalledPlugins) are full with the plugins I’ve previously installed.

EDIT: It seems that the rbxms of the general InstalledPlugins folder (the latter in the above list) get completely deleted. For my UserId folder, the plugin rbxms exist but in id folders and I’m not particularly sure what those numbers mean.

EDIT 2: And as it so turns out, they aren’t even registered as installed at all.

EDIT 3: Reinstalling the plugins doesn’t work either? I spent a good chunk of time reinstalling my plugins and they STILL won’t show up in the folder. Only three, inconsistently, are appearing.

3 Likes

This is still happening and extremely frustrating as an all around developer with a whole array of plugins I work with all the time

1 Like

Hey there! Just wanted to update and say that we’re investigating this issue.

6 Likes

I just casually opened Studio and all of my plugins have disappeared.
I have literally no idea how any of this has happened.
image


All of the folders inside the InstalledPlugins directory are empty as well. The plugin with the arrows is a local plugin stored in /Plugins

It may be because of a bug when installing a plugin/updating studio or a plugin, at least that’s what I’ve observed. But Roblox is “investigating this issue.”

Sorry this happened to you! Could you please share your last few studio log files with me? (See How to post a Bug Report - #12 by Roblox). My theory is this issue manifests over multiple runs of studio.