Animation editor closing when sellecting a tool

I’ve been trying to animate but i can’t change my tools!
For example i want to change to the move tool, but the animation editor cancels

Anybody else got this problem?


I’m also experiencing this problem and it’s extremely annoying!
Have you found a fix yet by chance?


Use the (R) key to switch (30)


I tried it. It still won’t work. I’ll probably just wait until tomorrow to see if it fixes by itself unless I find some other fix.

Its still not working, use moon animator until its fixed probably

Well, thanks. I tryed and it work’s!

That’s intentional. You could modify the animation editor plugin to stop that from happening. If you’re wanting to switch tools press the R key and it’ll cycle through moving and rotating (not scaling because that obviously wont work).

No that doesn’t work unfortunately
and also why would they disable it now if it worked before and wasn’t causing any issues

Your studio animator is brocken.

I started having the same problem this week. I installed studio on another notebook today and it worked fine in there. Thus, I believe Roblox pushed an update to Studio that conflicts with a local configuration that some PCs have.

Thanks for letting us know about the issue. This issue was caused by the Material Service beta which you can disable as a temporary fix. We are working on a permanent fix now which should be available next week.


The fix is now live! Please let me know if you still have any issues.


Everything is now working fine

Sorry for opening this up again but you guys did not solve this issue, or it’s happening again


grrrrrr it dont work 4 me 2 im so dsad

Hey so I don’t quite know if this will work for you but what I ended up doing was absolutely spamming my R key and it eventually fixed itself. Another thing that could have been the issue is the fact that roblox’s avatar importer / rig builder is kinda broken and doesn’t really build rigs properly. Try using a toolbox rig or moon animator instead. Let me know if this works!

I had this problem before, but when roblox auto updated it was fixed.

Who’s horse is that? also yeah same error

moon animator is too complicated for me

Hey there, I’ve encountered this exact issue and wanted to let you know. (It’s happening to my friend too.)
Edit: It only happens when team create is enabled, either with someone in or not.