Animations not replicating to all clients until getting close to them

I have a regular R6 rig with a ball attatched to the player’s arm using a Motor6D. The animations play perfectly on the animating player’s client, but on all other clients, they don’t play unless you get very close to the animating player.

As you can see, the ball is in its unanimated position until I walk up to the player.

I saw a couple other threads with people having the same issue, but found no solutions. One suggestion was to set the NetworkOwnership of the ball to animating player’s character, but this didn’t work when I tried.

Few notes:

  • The animations are created and played on the server
  • Issue doesn’t occur in studio test servers with multiple players
  • The animation in question is set to Idle priority

Any help is appreciated.

1 Like

I don’t have a valid solution to your problem, but from what I’m seeing here, you are trying to get the football’s grip correct?

If you are just trying to do that, there’s a nice plugin for that:
Tool grip editor - Roblox

Have the animations created and played on the client (Since the client replicates all animations to other clients automatically).

@RipPBB_TUD the football isn’t a tool, it’s a part connected to the player’s arm using a Motor6D. I don’t want to use a regular tool in this instance

@StraightScared I also tried that and it didn’t seem to change anything

Sorta wondering if this is a roblox bug

This issue has been going on for like a month now.

It seems to have something to do when they changed something about the Animators and so far, I don’t think any staff have tried to fix or noticed this issue yet since most of us cannot even post a bug report since its only for regulars.

Doesn’t really have a good fix but I linked some alternatives in my solution that players did to their tools so feel free to check their alternatives and see if one of them is fit for the way your tools are made.

1 Like

Great… well, hopefully they fix it soon. Thanks for those resources tho I’ll give them a try

1 Like

yeah even I am having a hard time with this issue too it’s been a while now and it was never fixed.

1 Like