Anims with priority higher than core overwrite c0 movements

I move the player character torso to look in the same direction as the camera by changing the Waist.C0 property. A month or two ago this would have worked fine and the arms would move with the torso when they were animated. However recently as soon as i publish an animation and use it with the arms, the arms move with the torso but dont change orientation. They keep pointing straight ahead and dont move up or down.

I ran a test with an old animation that was working perfectly. Its an anim that plays when tool is equipped and jusst moves the arm up. When holding the tool the arm would point in the direction the torso was facing. As soon as i republished the anim without changing anything it broke. Now the arm only points straight. Not aligned with the torso.

Oddly enough when i set the anim priority to core the problem is resolved. This isn’t a fix however, because i have multiple animations playing some with overwrite others and those anims need to be higher priority.


I have a similar problem. When rotating the waist based on the Y value of the camera, if the Y value of the rotation (EulerAngles) is any bigger than 0.1, the lower arms bend at a 45-degree angle sideways.
I tested the same code yesterday and it worked perfectly, and today it’s broken. I also can’t understand how changing the waist joint makes the lower arms bug out. Something is going on with Roblox.

(Getting back to the topic, mine has no problem with the animations, even with higher priorities)

1 Like

does the waist rotation work without anims?

This may have something to do with it:

cc @WoTrox


It does in 2 of the 3 games, and in 1 it doesn’t. Its a very confusing bug, and I hope they can do something about it soon

1 Like

it only happens with recently published animations. old ones work fine

this exact thing happens to me, i also made a post about it before seeing this one
my post

1 Like

Forgot to do this but i found the solution with the recent update that removed Animation Fix Blend property. Workspace has a new property called Retargeting. Set that to disabled and the issue should be resolved.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.