Anyone else experiencing this issue...?

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!
    I would like to add newly-made eyes to my model without ruining the rig and/or any of its animations.

  2. What is the issue? Include screenshots / videos if possible!
    when I rotate the head in the animation editor, instead of it and its children rotating, its parents and their child joints are rotating. This same issue happens when the animation plays normally.

  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    I looked at similar topics but couldn’t find a solution. In studio I: played around with it in the animation editor and re rigged the eyes. I tested it and allowed the animation to play to see what might be the problem.

After that, you should include more details if you have any. Try to make your topic as descriptive as possible, so that it’s easier for people to help you!

There are no errors in the output.
I’m using a custom character, the eyes were made by me and imported to Roblox from blender. All of this happened AFTER I rigged the eyes in.
They eye joints are children of the head joint.
All the parts are unanchored as well.

EDIT: This seems to be only occurring with the head and its parents/children (Chest, neck, eyes, head, shoulders, arms and front paws).

I would like to resume development on my game however this small little mess-up really throws a wrench into my plans and is the only thing on my mind as idk how anyone will be able to play if their character is bugging out all over the place.

If there’s a safe way to add more parts to model and rig it without ruining the animations, please tell me.

Could you provide a picture of the issue you are having.

Make sure everything but the HumanoidRootPart is unanchored.

I try t rotate the head, the body does instead

It seems like you rigged all of the motor6ds backwards, check if the model is anchored, if it is, unanchor it. Try it again, if that doesnt work, try rerigging your model using a plugin and tutorial.

ok ill try re rigging it and come back.

I re rigged it, tried it in the animation editor, the problem still persists…

Did you check if the model was anchored?

yes, its unanchored as well as all the parts in it.

What are you using to rig your model?

Rig Editor by goro7. I’ve used this many times and it has always worked.

in case it helps, here’s a screenshot of my joint hierarchy.
It starts at the HumanoidRootPart and then extends to the chest and torso and then so on and so forth.

Everything including the humanoidrootpart is unanchored, No problems have ever occurred with the humanoidrootpart being unanchored either.

Alright, I have moved my model’s eyes to ReplicatedStorage and disabled any and all scripts associated with them. I cannot let this one glitch ruin everything, especially when it seems I’m not likely to get a solution any time soon. So I am going to try to continue development on different aspects of the game. However, I’m gonna leave this topic as unsolved for now in case someone actually finds a solution to it as it would help a lot.

after some testing I believe I now sort of know the problem, which is that adding new parts to a rig seems to make everything all funky, if I take away the parts, everything goes back to normal. I’m going to mark this as “solved” being that I can’t find any solutions to the matter and probably won’t anyways.