Are Xbox 360 gamepads still supported on Mac?

I am trying to plug in a wired Xbox 360 controller on an iMac. The light blinks for a moment, and then turns off. I have tried to use it in-game and in studio with no luck.

I used to be able to use them, but not anymore.

Running 10.13.6

Are they still supported?

Tried a driver and XB1 controllers as well with no luck.

2 Likes

In my own experience with it, no, but I myself have only tested it once. It could very well have been my hardware.

I will still give a definitive answer of: no, I don’t believe they are still supported.

It worked fine for me. I’m on windows though, so that might be why it plays more nicely. Found out that driving with a controller in Jailbreak is less than ideal.

I had the same problem a few years ago when I owned a mac computer. The lights blink because the mac can supply power to it - but nobody is home because OS X has no idea how to communicate with it.

Luckily someone did create an XBOX 360 controller driver for mac which can be found at the below GitHub link;

It can be installed with relative ease but I don’t have access to an mac anymore meaning I cannot test if it still works. It was last updated in 2019 so a safe assumption is development is still continuing on it.

4 Likes

I tried this driver. 360 controller connected, but Roblox still couldn’t recognize that I was using it. Tried three different games, including a baseplate. No luck.

I also tried connecting my Xbox One controller both via bluetooth and micro usb with no avail, with and without the driver.

1 Like

Just tried it with my windows laptop. Plugged it in and it immediately started working. I guess this is just an OS problem?

1 Like

I’m going to bump this, Xbox one controller doesn’t work for me either. Driver works, it shows me pressing and moving joysticks properly. I think it’s Roblox not recognizing it.

A few years ago, I had no trouble using a Controller on macos with Roblox. Not sure what changed or when. Would love controller support to come back.

9 Likes

I believe a software change in a MacOS version had to do with this issue. I tried it on MacOS Big Sur and it seems to not work anymore. Have you tried the bluetooth version of the gamepad or the wired method?

I’m going to guess you’re using a wired connection, if so try connecting over Bluetooth, a few months ago I did this on my MacBook and it worked kinda. It might not anymore with all the OS Updates but if you haven’t tried it, might work for you.

1 Like