Xbox Controllers don't work on macOS

At some point, Xbox Controllers no longer worked with Roblox. When installing the correct drivers, the drivers show your moving the joysticks, clicking buttons, etc. When you load up Roblox, the game doesn’t recognize the controller at all. This happens 100% of the time.

It’s possible this began with Catalina which is a 64-bit only release but I have no clue how this all works and I’m just spitballing on when controllers broke down. I know they used to work years ago when we tested Jailbreak.

I’m currently on Catalina V10.15.6. I’ve only tried a wired connection. Mac has a hard time recognizing controllers over bluetooth in my experience.

Bonus thread with others talking about the same problem: Are Xbox 360 gamepads still supported on Mac? - #7 by asimo3089


I think you need to use an xbox one controller on a mac.


Hello, thanks for the report!

Can you verify if you are testing an Xbox One or Xbox 360 controller?
On macOS, the currently supported controllers are:

  • Xbox One
  • Dualshock 4
  • Controllers that support the MFi standard

If your controller is not working in Roblox, can you please verify if it is recognized on your system by testing it, for example, here:


I’m abroad right now so cannot test my controller with that website. But my Xbox One controller did not work on MacOS for Roblox.


That’s very weird. Wireless has worked for me, even on Catalina. Maybe give that a try? If it’s a 360 controller, I doubt it would work. A Bluetooth Xbox One controller should work, it being MFi.


I have been having problems using my Xbox One controller on my Mac as well. My mac detects the controller with a wired connection or bluetooth, but it doesn’t work on Roblox.


Would it be possible for you to test your gamepad setup by going to this site and pressing buttons / moving the analog sticks to see if if works? It would be useful to determine if this is a problem with Roblox itself.

Also, bluetooth capable Xbox One controllers are natively supported by macOS without the use of any third party drivers, in case this is causing any issues.


I am able to confirm that my gamepad detects input from the controller, both from wired connection and natively supported bluetooth connection. It works for other games on my Mac but still isn’t working for Roblox.


I had to check because even I wasn’t sure. I am using an Xbox One controller. It looks like this.


i have an xbox and an xbox controller and a macbook air running catlina and the controller does not work but it works fine on my windows pc and my xbox (i typed this on mobile so there might be spelling mistakes)


Funnily enough my little brother had this same issue with an Xbox 1 controller on a Windows 10 laptop. The system recognised the controller & it worked fine everywhere but one day ROBLOX stopped registering his controller inputs. I don’t know what caused this issue and I’m pretty sure it still persists to this day.

1 Like

I cannot reproduce. I am using a 2015 Macbook Pro with the same controller as you had shown. I am running Big Sur 11.2.

Maybe Catalina is no longer supported? That is the only thing I could think of. I have looked and there has been no recent API changes regarding this.

I reccommend to try Bluetooth again as that is what I use. If you are still having issues, which model Mac do you own? Maybe some kind of internal issue if it is quite old.

Good luck solving this issue and have a nice day