Asset Manager is Here (BACK IN BETA)

I posted the critical bug report I’m replying to in April, and it never got addressed. Three full months ago.
Now the asset manager has been forced on me with no option to switch back. Seriously?

It’s still only loading that one package, and now there are no duplicates, but there is also nothing else there, at all, at a moment when I need to update multiple packages in my game for a critical bug fix. Just another reason to use Rojo and abandon packages, I guess.


The only benefit is the appearance however it is very buggy and it fails to load the icons!
I thought this new interface will give us a way to separate meshes like making folders for games with hundreds to thousands of meshes, Images, etc.

I want the old game explorer Roblox please :sob:


I personally see very little benefit to having images for each item, if I upload something - I generally already know what it is and have uploaded it for a reason. A lot of the objects I upload are split and are visually unidentifiable on their own, this is why I rename them in the 3D software I use. What would have been nice is the addition of a file system, a good example would be blenders “Collections” its simple, clean and easy to use.

The alphabetical sorting system is kind of annoying, I would rather see what I uploaded chronologically and not be forced to use the filter system each time.

The fact that we can no longer select items via shift clicking is a big issue.

In conclusion, I would rather have the old game explorer back - as would many others it seems. Perhaps in the future some of these changes can be added and be optional.


I’ve noticed that there is no option to archive meshes or images with the asset manager

Are you planning on adding it in the future sometime? Because I would love an option to do so.


It seriously looks good, no doubt on that, but this is released way too early. It errors all the time, has small things not working and just things that shouldn’t be removed as feature. From my opinion, the ideas of this project don’t come along with features we actually need. Just like the bulk import, the idea of that is to import a large amount of meshes in once. But it doesn’t come along. Now I have like 500 meshes just randomly in an endless folder, of which I need to select everything manually holding Ctrl. The whole point of this new project which should make things easier to upload and just find things back, didn’t pack out well. In general, I just hope that we can re-enable the old Game Explorer and actually choose between this new project, and the old Game Explorer.


Among other bugs, Asset Manager also breaks the cursor icon, making it stuck.
Pay attention to the cursor in this video. Notice how it changes when I click stuff in the Toolbox vs stuff in Asset Manager.

Once I click anything in the Asset Manager, the cursor icon no langer changes when I hover over objects in the Workspace, which is extremely confusing, and forces me to restart Studio for it to get unstuck (and then I have to avoid even slight use of Asset Manager, or it will get stuck again).


You can try to fix that by clicking again on the mouse cursor next to move and scale. But yeah, this shouldn’t be working like that in first place.

I’ve tried that already. So far the only way to get it to unstuck is to restart Studio. If I click anywhere in the Asset Manager widget, it’s stuck for the rest of the session.

1 Like

This is also an issue using the Game Settings window.

1 Like

How do you create a new place now that I can’t do this

When I try to from the game’s page it shows:

Does this imply I can upload a place through the asset manager?image

Would seriously be a good idea to revert to the one before asap.
If not, at least give us an option to use the old one.


You can do so by going back on the main asset manager window and right clicking the folder


There definitely should be a better way to do it, like right-clicking while inside the place folder. General complaints I have really of the new asset manager is that my workflow is now almost double or triple time slower using this. I’m sure it might get faster once I get used to it but these little things adds up and I hope they can add some needed quality of life enhancements.

It also seems like they did not fix this package issue either, which is a big problem.


That’s such a bad User Experience, I didn’t even know I could right click


I assumed I would be able to create a new place by right clicking in the place content area (but not on a place) within the places folder, but got this error message:

1 Like

That’s actually pretty weird, I tried right clicking but didn’t work lol
Could have been some rare occurance I guess.

This is awful and unpractical, it takes way more effort to do things now.


As with most posts in this thread, I have now encountered an issue with the Asset Manager that is a regression from the Game Explorer and directly hinders work.

I can’t see my images anymore if I upload them using Bulk Import until I restart Studio. Not to mention every time I open the Images folder, my console is flooded with ContentProvider:PreloadAsync errors.

This really hinders my workflow because my images are not easily identifiable by name, and I’d like to be able to see what they are in order to copy the Asset Id.

This was not a problem with the Game Explorer because I could see a little preview of the image, even if it hadn’t passed moderation yet, which let me tell apart my images before copying the id.

All the pictures seen here have passed moderation, but don’t show up because I haven’t restarted Studio.


So, it has been said a few times in this thread already but I feel as though I need to mention it as it impacts me and my work directly. In the game explorer I was able to drag and select, shift-click-shift select, and basically work with large amounts of content easily. I am unable to do this currently. I have an import of 80+ meshes that takes considerably longer to ‘import with location’ now because I cant simply select all the newly generated meshes in the asset manager. Please fix this.


I don’t really like it, especially for the alphabet-sorting system. We could choose or switch between alphabet-sorted and date-sorted. When I import a mesh, it takes me more time bringing it in game instead of before, only because of that. Also, maybe a possibility to change the icons ? Or maybe even better, instead of folder icons bringing a sound icon for sounds, mesh icon for meshes, etc.

Perfectible. But as a developer, i’m admirative to any dev. work. Continue that, don’t let it as it is !


This has really been messing with my workflow. I like the idea of alphabetical sorting, but I feel that it is pretty useless. There should be an option where it sorts your assets based on when they were uploaded, so I can find my recently uploaded assets easier. Also when I click “Insert With Location”, it should automatically select all the MeshParts inserted in the workspace (Currently it only selects one). I used to be able to do these things with the game explorer.