Avatar page incapable of loading all clothing and also throws HTTP 400 and 429 errors often

Reproduction Steps


  • Log in as a user who has a fair amount of classic clothing
  • Head to the Avatar page
  • Click on a classic clothing tab (Classic Shirts, Classic Pants)
  • Attempt to scroll down to reach the bottom

Per the device info page:

  • User agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/104.0.5112.105 Safari/537.36
  • Platform Type: PC
  • Device Type: Computer

I am using Vivaldi browser (chromium). I have heard from others (but not personally confirmed) this bug also occurs on Chrome and on the Roblox Mobile app.

Just as an FYI - I disabled all Roblox related extensions prior to recording these videos and because I have heard others are experiencing the same problems I assume that this is not extension related.

Expected Behavior

Clothing should continue loading as the user scrolls down until they eventually reach the end of their inventory.

Actual Behavior

There have been 3 errors I have seen which may occur:

  1. No HTTP errors (most common) - the user is not able to scroll down any farther. No errors are thrown by the inventory API. Attempting to change tabs does not fix the error.

  2. HTTP 400 error - user receives error message on the top of the screen Failed to load assets list. which seems to be displayed whenever an HTTP 400 is returned. Upon trying to scroll down to show more clothing, HTTP 400 is repeatedly thrown. The return JSON I received for Classic Pants is:

    "errors": [
            "code": 0,
            "message": "Invalid cursor: Cursor does not contain requested type, 12.",
            "field": "cursor"

  1. HTTP 429 error - this error is not as common, but from my experience I suspect that scrolling down fast causes this rate limit (no surprise). Regardless of how it’s caused, HTTP 429 errors are still frustrating for the user-experience and it would be nice for Roblox to be less restrictive over this rate limit.

Issue Area: Roblox Website
Page URL: Roblox
Impact: High
Frequency: Constantly
Date First Experienced: 2022-08-18 00:08:00 (-04:00)
Date Last Experienced: 2022-08-23 00:08:00 (-04:00)


i cannot wear 99% of my clothing, and since Roblox removed the “wear” button that you can use on the page of a shirt/pants, it is completely broken and i don’t know any way to actually wear the clothing i bought


This is a massive issue for me as well, i own more then 100+ clothes and i can only load in maybe about 20 before it decides to no longer work. My only option to wear other clothes i have is i have to go to


and manually find the id of the asset i want to wear within my inventory page and insert it there.

Edit: I also forgot to mention this doesn’t matter what browser or device im on, it happens everytime even on the apps for phone and windows.


I have been experiencing the same issue for several months, and its really frustrating. I do not understand why roblox has not made anything related to this issue, or solved it just yet.

Unacceptable, I have hundreds of clothes that now I can no longer wear.
Trying to make new outfits on roblox is frustrating now, as you spend hours , trying to make the page load the items.

Edit: My only solution was to go to my inventory, search the clothes and when clicking the “···” wear the item, but as always, roblox removes useful features, so this avatar page bug does affect heavily.


A massive issue indeed, given the ability to wear an item from the item’s page was removed, I was left with either having an outfit with the accessory I desired already on it, or I pray to god that the avatar page doesn’t throw an error while trying to scroll. It’s incredibly painful to make avatars now.


it’s been seven days, of being reported, and it’s hilarious roblox still hasn’t acknowledged this. our older clothes has literally been rendered useless as there isn’t a way to wear them without the usage of API - though your average Robloxian wouldn’t know that.

also amazing documentation of the bug.


The bug has existed for at least a month. I’ve seen social media posts dating back to July talking about the bug, and I was surprised it’d taken so long for it to be reported on the Dev Forum, even more so at the lack of response from Roblox concerning the issue.


Thanks for the report and sorry for the late reply. I filed a ticket to our internal database and we’ll come back with updates.


I have quite a few clothing items and this prevents me from scrolling down and wearing them. Due to the removal of the button to manually wear clothing, this is even more frustrating.


The issue has escalated. Now when scrolling down on the “My Costumes” section in the web version, the page gets cleared and it displays a message saying “You don’t have any costumes. Try creating some!” What’s worse is that the outfits do in fact load in, you see them pop in with their names, icons, everything, but moving the page down gets rid of them all until you re-open My Costumes.


I have had this issue for 9 months at minimun, It also occurs with accessories and hairs. Just recently it has gotten so bad it will not load more than 40 accessories.


Bump, I have been experiencing these same issues for months and its extremely difficult (if not impossible) to deal with.


i cant even see all of my mine at once, so it makes some outfits impossible to load. Its super irritating. hopefully this means they are working on that section, maybe they will add more outfit slots?


Friend of mine has been having this issue as well. A lot of their older hats cannot be worn (this doesn’t just apply to classic 2D clothing).


Also have this issue, sometimes I can’t see any of my clothing.


Roblox has clearly put a lot of effort onto avatar customization, such as adding UGC items, layered clothing, and more. With all that effort being put onto UGC and avatar customization, what is the point if users CANNOT even access the items they BOUGHT because of this bug?
I hope this bug gets acknowledged and fixed because it is highly infuriating and impacting a lot of users like me.


I thought I’m the only one who encounters this issue because of my page customize Chrome extension. However, I tested it in different browsers, and it’s still the same. Hoping a fix by Roblox honestly.


This is affecting me too. The avatar tab is completely broken and partially unusable, and completely unstable. Costumes won’t let me scroll down.


To be clear this is a problem with the system itself, so the issue occurs on ALL browsers and platforms.


I have the same issue but with the outfits section. It’s really annoying since I have to use the Roblox app to be able to do anything with my outfits as they just remove themselves suddenly from the list. They are still on my profile and I can select them by zooming all the way out on browser.