BasePart Materials Render Glowing Artifacts When Shadowmap and EnvironmentSpecularScale Are in Use

Around 3:50 PM CT today (Wednesday, June 17), I opened my place in Studio and noticed these unusual glowing colored patterns radiating from certain parts of my building. This was NOT happening last night:

Warning: Bright Colors

Game link (not public): https://www.roblox.com/games/2705153913/Trowelville

After a little experimentation, I’ve figured out the basics for a repro:

  • Lighting.Technology is set to Shadowmap. This bug does not affect Voxel or Compatibility

  • Lighting.EnvironmentSpecularScale is set to any value above 0 (Higher value intensifies the glow)

  • Place has visible BaseParts

Here’s what it looks like in an empty place file:

More Bright Colors

A Part with Fabric

A Union with Wood

A MeshPart with Sand

A TrussPart with Brick

Most BasePart materials are noticeably affected by this. Effects carry over to Play Solo in Studio. It seems to vary depending on the lighting settings. Does not appear to impact Terrain.

I suspect this has something to do with the latest Roblox release, 437. Assuming that the repro requirements above have been fulfilled, this bug occurs in all games.

Device: MacBook Air (2012)
OS: macOS Catalina, Version 10.15.5
Graphics: Intel HD Graphics 4000 1536 MB
Studio Version: 0.437.0.406875

If there’s anything I missed please post below.

6 Likes

This is very strange. Does it look like that when you play the game?

I tried again in a Roblox server and got the same results:

1 Like

Is it just that game or all of your games. I don’t really know what the problem is.

Yes, this bug is happening for all of my games. Follow the repro steps, create a part and set its material to Fabric. Do any of its surfaces have markings like this?

I am not sure then sorry. I hope you get it fixed.

Have you tried re installing roblox?

Reinstalling Studio and the Roblox Player did not work, the bug still persists

I have tried several times to recreate the exact environment.
Perhaps it is just your hardware. Try updating your drivers.

1 Like

I noticed this happening in Arsenal just earlier.

I am running Mac High Sierra.

2 Likes

My Mac is up-to-date; there is nothing I can do in that department. I’ve restarted it as well to no avail. This could be a Mac-only bug, what device are you using?

1 Like

I am on Windows 10, so it’s probably the new update.

1 Like

I’m not having this issue. Although I’ve seen issues like this in the past with Minecraft on old devices back in the day (5 or 6 years ago). I think a key player isn’t some bug since many people don’t seem to have the same issue. It might be that your MacBook is reaching its limit, 8 years old may be usable but for advanced graphics settings it may not be able to handle it.

@KeysOfFate are you running on an older device as well?

Not a computer engineer but I think those with older devices should test this out to see if they have similar issues. Seems isolated in some way

1 Like

I’m using a 2013 mac desktop. I’ve been able to render things just fine until yesterday.

2 Likes

Are you able to send screenshots or more info on your specs?

Device: iMac 2013
OS: macOs High Sierra, Version 10.13.6
Graphics: Intel Iris Pro 1536 MB
Studio Version: 0.437.0.406875

Arsenal:

2 Likes

So I saw two people have replied having this issue.

This might be an issue with your PCs and ROBLOX’s compatibility. These errors are usually caused by faulty code, bad graphics cards, or your PCs specs not being able to handle what ROBLOX wants it to handle.

I recommend just waiting for ROBLOX to update again as there is not much you can do.

1 Like