Blueprint 1.1.0 | Automatically replace the default script source with a template

Blueprint


a Roblox Studio plugin designed to replace the default script sources with a dedicated template seamlessly

GithubCreator MarketplaceDevforum


Installation

Creator Marketplace :computer_mouse:

The Creator Marketplace is the easiest way to install Blueprint. You鈥檒l get access to automatic updates and be able to use the plugin anywhere you have Roblox Studio installed.

Manual Installation

  1. Download the plugin (.rbxmx) file from Releases
  2. Drag and Drop the plugin file into the Roblox Studio 鈥淧lugins Folder鈥 (TopBar 鈫 Plugins 鈫 Plugins Folder)

Usage

  1. Select a 鈥淪cript鈥 Instance in the Roblox Studio 鈥淓xplorer鈥 with the desired source template
  2. From the Studio TopBar go to 鈥淧lugins鈥 鈫 鈥淏lueprint鈥 Toolbar 鈫 鈥淪et鈥 Button

Now, create a new script instance to witness the source get changed!

Example

3 Likes

This is nice to use, but can you make it so that ModuleScripts has the

local module = {}

return module

by default before/after your code, or change it in a way where we can put different sources for different types of scripts?

Most of the time I never really required different sources for localscripts or scripts, since 99.9% of my code is inside modulescripts.

I added the functionality for different blueprint sources for different types of scripts on the 1.0.2 version anyway, since it was quite the simple thing to add :+1:

1 Like

Thank you lol, most people require player variables at the top of localscripts and stuff so its just kinda good to have in the plugin

image
image

For some reason, when I make a new script, the script editor does nothing for a second, replaces the source with the code i set it to and shows this message for half a second, and then it switches back to the default roblox script source without changing anything

edit: Turns out it鈥檚 because of team create, because trying in an empty baseplate with team create off works fine. Is there a way to fix this?

I just disabled it and enable it when I鈥檓 working with a lot of scripts because it just kinda stops working for me randomly, and that random delay, but I don鈥檛 think the delay is preventable.

Hey, updating to the newest version of the plugin (1.1.0) should iron out the functional issue while in team create now.

Alternatively, you can enable 鈥淒rafts Mode鈥 from Game Settings to disable the 鈥淟ive Scripting鈥 feature that is the main cause.

1 Like