BodyPosition's power is suddenly less

PC Info: Windows 10, 22H2

Date First Experienced: September 7th, 2023 (could’ve been a few days prior)
Data Last Experienced: September 13th, 2023 (still ongoing)

Reproduction Steps:

Either use this example kit I created
MovingPlatformExample.rbxm (9.3 KB)

  1. Add 3 parts; one an unanchored platform with BodyPosition in it (and maybe some Gyro to keep it from wobbling), the other two are anchored, non-collidable parts representing ‘Start’ and ‘End’ (can add
    similar midpoint parts too)

  2. Change up the BodyPosition’s D, P and MaxForce values and create a script.

  3. Inside the script, you can initially put the BodyPosition of the platform to platformPartName.BodyPosition.Position = startPartName.Position

  4. Upon waiting a loop, pressing a button or some, the BodyPosition’s position can be set to the End part’s Position. A bit later it comes back to Start.

Here is a video showing the issue:

The video shows the exact same behaviour as currently in game (only since a while)

  • it being a tiny bit underneath the start/end is normal because of the set Power and Dampening. They’re set to these values so the platform doesn’t zap from A to B. This ONLY happens after it’s been ‘touched’.
  • I did notice that on the second play, from about minute 1:49, the the platform almost took seemed to make a slight parabol shape, going up and then back down…? Maybe that’s a lead
  • In an additional experiment, I placed down a part on the platform → It did NOT ‘activate’ and kept going at the weakened manner

Expected Behaviour: Platform should behave just as shown on 0:49, without needing this ‘activation’
Actual Behaviour: Platform seems to sink down and only returns to its actual power when triggered by a Zombie, Player or NPC

Besides that, whilst playing I noticed the floating orb, which moves between two parts with its BodyPosition, has suddenly become a lot weaker: It currently drags down a good 1-1.5 studs under.

Obviously I never changed any values, which must mean something physics related has happened. Heard someone mention how physics have changed a lot as of recently. Perhaps this also applies to the Power and Drag of BodyMovers?

This has essentially broken both visual, as well as core interactions in my game. What has changed as of recently?

To try and find an alternative solution for each individual affected model, I tried changing the initial BodyPosition’s position, which is what seemed to drop.

For moving platforms that go from one part’s position to another by a button, the object sinks whilst Running the place in Studio. I also increased the initial Position by about 2-3 and it worked.
When the platform is activated during this Run session, the midpoints and end it does sink again too, whereas in an actual game, it doesn’t when I get close or within… rendering distance… or so?

The position should be equal to the cylinder.

Upon touching the platform, it raises up and does get to about the desired height…

Similarly, when spawning an NPC like a Zombie on top of this sunken platform, it slowly moves up too, just beneath where it’s supposed to be.


Thanks for the report! We’ll follow up when we have an update for you.


should note bodyposition is a deprecated class that barely gets any updates, doubt this will be fixed

Its behaviour suddenly changed, causing it to no longer function properly. Obviously something’s caused this sudden change, which internally, I’m positive they should be able to resolve.

The issue still persists. Any heads up on the issue?

It still hasn’t been fixed!
Any news?

Can confirm bodyposition’s power got severely lowered. This is especially noticeable on the Y axis due gravity.

Please fix the power issue of bodypositions.

After testing out some settings, it seems to be related to the PhysicsSteppingMethod set at Default / Adaptive. Mainly Adaptive kills the power, but Default as well. Fixed seems to return the original situations I prefer. I think they changed Default to be equal to Adaptive some time ago, but the docs still mentions Fixed is Default (PhysicsSteppingMethod | Documentation - Roblox Creator Hub)

Can you try to see what happens if you set the PhysicsSteppingMethod to Fixed?


After changing the PhysicsSteppingMethod from ‘Default’ to Fixed, it indeed seems to have fixed

The orbs are floating back like normal and the platforms no longer require ‘physical activation’ from a Humanoid (it be a Player, Zombie, etc.)

Regardless of it being ~30 days later, I thank you for the solution (!!), as I was starting to doubt this “update” that I’d be receiving on the issue.

This does raise some questions…

  • What else is affected by the change from Fixed (old default) to Adaptive (new default) PSM besides BodyPosition?

  • When I opt to change ‘back’ to the previous default - Fixed - could there be any unwanted consequences it brings with it somehow (new ‘Fixed’ being somewhat different from old ‘Default’)?

  • All these other Game Behaviour properties, have they also seen a change from old to new ‘Default’ ?(I’m not sure if I’ve noticed anything else much, but this change has me concerned)

And eh… will I have to manually update every Sub Place’s PSM / PhysicsSteppingMethod now?
It can’t be done from the Main Game/Experience hub :thinking:

I can find that they’ve recently changed Default to Adaptive back in July (PhysicsSteppingMethod: Now Set to "Adaptive" as Default). I’m not sure if this means that the ‘Default’ option equals Adaptive, or that Adaptive is simply the default setting. I also found some other posts (Issues and physics-related flinging caused by recent Roblox update - #5 by 0Tenth) mentioning that the old bodymovers prefer to work under Fixed.

It basically adds up that Adaptive is now the new Default. Whether this is intended or not is for Roblox to say.

I can only say that this could break various old games. My assumption is that most, if not all bodymovers are affected by this change. Indeed, the only solution is to go into the place, change the property and save / publish that change.

Thanks for reporting, I’ll be taking a look into this to see if we can improve things. Apologies for the troubles.

1 Like

Just changed every Subplace to the ‘Fixed’ PhysicsSteppingMethod.

This inexplicable platform behaviour had me groping in the dark for a long time, unable to find the root or cause to the sudden problem.
Hopefully the manual switching has solved the issue for good and no further complications arrise, as expressed in the message above…

Would’ve preferred the new ‘Default’ to apply not to existing places :see_no_evil:
Thanks for the help :')

Hey MilanoMaster,

Just letting you know that this issue should now be fixed. Using Adaptive as the stepping method should not have noticable impact on the behavior of AlignPositions now. :slight_smile:


I noticed some changes, yes!

It seems that for all three stepping methods (Fixed - Default - Adaptive), parts with BodyPosition now all feature the same physics.

quick mention:
-The subtle, natural / ordinary dip (0:55 on the clip of first post) always occured to a part with BodyPosition when the power wasn’t on the extreme - even before the change to ‘Default’
-The exaggerated, abnormal / extraordinary dip is the big lack of power (0:16 on clip; until an NPC/Player/Humanoid touches) which this thread was created around

It appears that this subtle dip is now also gone, on every stepping method.
This means for example the platform no longer slightly lowers itself when power isn’t sufficient.
This also means BodyPosition with this insufficient power added to a Player keeps them set in place.

There is this instance where BodyPosition is added to them by this kind of Sorcerer. The force of this BodyMover tries to keep the NPC or Player in place, but you can resist and slowly move away from the point set as its position.

Right now however, after this change from a day or two (?) ago, you’re just stuck and can’t move away or resist whatsoever. This is because the subtle dip (it allowed you to slowly but surely move away) has been gotten rid off on every Stepping Method. When I wrote my latest message (October 17th), changing the Stepping Method to ‘Fixed’ removed the exaggerated dip, but nicely kept this subtle one!

I thought tweaking the Power, Damping and MaxForce would bring back the ability for the Player to resist this force, which after a lot of trying seemed to sort of work.
Something to the movement or force put towards it seemed off however. It felt as if the force wasn’t constant and that with every movement direction I took, I was able to manipulate the force to a point where sudden movements affected the force too much.

I set up a basic test with a part to check on this:

You can clearly see the part doesn’t move whatsover, even when the Force is lower. No more subtle drop…
Only when it’s reached a Force low enough - changes occur.
At 0:31, putting in 1100 wasn’t enough to get the part back into the air, whereas on 0:43, 1100 was enough to keep it afloat somehow.
It seems as if it’s “the one or the other” now and the forces impact each other.

I greatly appreciate the thoughts on how to improve the methods, but with the abnormally loss of power gone and the subtle dip still there (message from October 17) the interactions and physics worked well from there!

Fast forward to today, the abnormal loss is gone, but so is the subtle dip - essentially causing another complication :sweat_smile:

Was it intended for either Stepping Method to now give the same results regardless, or can one method allow no dips whatsoever and another keep just the subtle one?

~ A few months ago : Subtle dip, worked fine :+1:
~ September 14th / Post creation : Abnormal drop :-1:
~ October 17th (I updated the stepping method to ‘Fixed’) : No abnormal drop, but still subtle one :+1:
~ November 9th : No abnormal drop, but no subtle either :-1:

You and I are having similar issues with BodyPositions. I have a game where players fly around using BodyPositions, and I experienced an issue similar to yours where flying players would slowly fall down while idlling when they should have been in a set position. What fixed this was reverting the instance to a previous version history then importing all my newer models to the old place. This fix was great, until sometime around November 7-8 my players report they suddenly are either falling or floating upward but nobody is staying in one place. I will work to find a solution to bring the physics back to what they were and post it here.

Edit: It appears primarily the Y-axis is what is affected like you stated previously. There are little to no differences in regular flight except the slow falling or floating upward.

This update essentually ruined the main mechanic surrounding my game. I use BodyPositions to have characters move around while being pulled towards the players. BodyPositions seem to have been broken in away that prevents said characers from move at all except for the force applied by the BodyPosition. There doesn’t seem to be any Class that behaves similarly to BodyPosition before it broke, so this leaves me with no alternative.

Apologies for the issue. Can you send me a placefile so I can further look into any problems?

1 Like

You can use the non-deprecated constraints to obtain the same behavior. BodyMovers are deprecated and janky, and are on minimum maintainence at the moment :sad: Using AlignPosition is a much better choice in 99% of cases.

We will still look into this further though! Apologies for the issues.

AlignPosition does not appear to behave the same as BodyPosition as it does not have a Dampening property. If they are supposed to behave the same then AlignPosition is suffering from the same issue that’s affecting BodyPosition. After this change came out, additional forces that can be applied on a character such as walking is effectively nullified when a BodyPosition or AlignPosition with the same properties post and prior to the update is present in the character.

The properties that I have applied to the BodyPosition are
MaxForce is 8000 on all axis
Power is 25
Dampening is 7
The purple character has a Walkspeed of 30 yet it is unable to move at all.

As demonstrated by the video below, you can see that the purple character is trying to run away from the player, however the force applied by the BodyMover entirely takes over all additional forces. Prior to this update, the purple character was able to run around while being pulled towards the player by the BodyMover. I’ve tried changing it to AlignPosition, however the strange behavior continues to persist.

1 Like

Is there a way I can provide a place file privately?