Bug Only Occurring on One Computer

Let me just preface this by saying I don’t know if this necessarily counts as a bug that should be reported because I have not heard of this ever happening to anyone else, so I am posting this here.

So for the past week I’ve been encountering a bug with my game where I code it to so the player’s camera zooms into first person mode but the camera is unable to rotate and the mouse doesn’t lock to the center of the screen the majority(~95%) of the time. I tried as many ways as I could think of to fix this issue while I was at college and on my laptop, but to no avail. I came home this weekend and wanted to compare the code to an older save file on my desktop. I tried to run the same place(which has been published to Roblox so I know I am trying the right one) and the bug did not occur once. I thought maybe the powerline connection to my PC was the culprit, so I disconnected that and connected to the Wi-Fi, but with the same result. I even ran it on my laptop a few more times just to make sure, the problem persisted.

I have tried everything I could think of to remedy this situation but am out of ideas. Does anyone know of a reason as to why this would be happening or how I could possibly fix this? I wouldn’t want to publish a game that might have a game-breaking bug for some users.

tl;dr: I have a bug happening in my game on my laptop, but when I run it on my desktop the bug doesn’t occur at all.

Have you tried plugging in a mouse into your laptop?

It may have something to do with your laptop’s built-in mouse.

I posted this months ago but it may be relevant:

It happened (and I think still does, haven’t tested in a few weeks) to my laptop. I couldn’t get the mouse to lock in first person mode.

I can reproduce this, albeit it’s a bit… odd.

  1. Open studio
  2. Create a new ScreenGUI, put it in StarterGUI, and insert a frame of size {1,0},{1,0}.
  3. Set the frame’s BackgroundTransparency to 1
  4. Set its Active property to true
  5. Insert a *Button object inside the frame and have its Modal property set to true.

Do you happen to have any GUI setup similar to this?

I’ve had this issue before and it was caused by the same thing (although OP is referring to the bug only happening on one device)

I use a wireless mouse with my laptop. I’ve tried with it removed and I’ve tried using the touchscreen to control the mouse but nothing worked.

@CodingLucas I already checked every ui button element to make sure Modal was false

1 Like