First Person mode does not lock the camera

  • Describe the bug. Describe what is happening when the bug occurs. Describe what you would normally expect to occur.

Whenever I use First Person mode on my laptop, I cannot move my camera (like I wasn’t in First Person). Instead I have to move it by holding down the right mouse button. It’s very inconvenient when I am not at home with my desktop computer (where First Person works as expected). This happens when I zoom in by using the mouse wheel AND when I force the zoom via scripts.

  • How often does the bug happen (Everytime/sometimes/rarely)? What are the steps that reproduce the bug? Please list them in very high detail. Provide simple example places that exhibit the bug and provide description of what you believe should be the behavior.

This happens every time I run play solo OR test server on Roblox Studio ONLY. The bug does not occur online during an actual play session.

  • Where does the bug happen (www, gametest, etc) Is it level-specific? Is it game specific? Please post a link to the place that exhibits the issue.

This bug is not game specific, as I tried it both on my testing game for Notoriety as well as an empty baseplate. Once again, it only occurs in Studio.

  • Would a screenshot or video help describe it to someone? If so, post one.

My character should be turning when I move my mouse:

  • When did the bug start happening? If we can tie it to a specific release that helps us figure out what we broke.

I think I first noticed it while I was still in school, probably a month or two ago. That was before I had to use my laptop a lot, so it didn’t really bother me.

  • Anything else that you would want to know about the bug if it were your job to find and fix it.

I think this may be device specific. Here’s my info:

My computer does have touch screen capabilities. Surface Books also have detachable screens (although mine is attached when this occurs). Maybe the game thinks I’m using a tablet, even though Roblox doesn’t offer me touch controls or anything like that.


Happens to me sometimes

Go through all your GUIs and make sure Modal is false

Iff all GUIs have Modal false, then you will be able to lock mouse once in first person


I though that might have been the problem, but this still happens on a blank level so I don’t think that’s the problem in this case. Also, the same game’s first person mode works on my desktop but not my laptop

This same bug is also happening for me, in both first-person mode and shift lock. I’m using a Windows 10 laptop with no touch capabilities.

1 Like

I think I’m having the same issue: Roblox player not capturing mouse properly

That sounds similar although this bug happens for me no matter where my mouse initially is

Any word on this? It’s still happening.

Yup, I found that going fullscreen is a temporary fix but it’s not always desirable. I would greatly appreciate if this could be fixed.


I have been having this issue for months on my desktop with the same OS, but my Surface Pro 4 doesn’t seem to have this issue. This also happens on-site for games (and even baseplates) that have this issue in studio. Is there any update on a solution for this?


Do not necrobump old bug reports.