Bug Server on a game I develop on is "broken"



Problem already resolved.

1 Like


Are you by chance running a while loop in your game? This may be the cause - a hanging loop which stops the game time script (not letting you play)

What about in studio, have you tried Play testing there? Does that work? If not are any errors printing out?

There are a few but I have been slowing them down.

I will try this now. Hopefully this works.

https://gyazo.com/bf3f257fc58dd0aa4f2372b502c2576c @SkoobiDoobiDoo

What do you mean by ‘slowing them down’? While loops in a lot of cases can be replaced with renderstepped etc which if I’m correct is less demanding.

Like disabling the while true scripts, that did nothing.

1 Like

I just managed to get in to the game On studio only.

Just in-case have you tried reverting the game version back to an earlier stage? (If it won’t impact your progress that heavily)

This is what I get in the dev console:


502: API Services rejected with error. ^

This was getting spammed:


What http calls do you do?
Any http call.
If its getting spammed, are you doing some http call every frame?

Not sure if this counts as one but I have a datastore for in-game money.

Oh yeah, and we use Adonis admin trello for bans.

How updated is the Adonis script in regards to the Trello aspect?

Trello made an update here GET requests would require a token and a key, but I don’t know if the creator of Adonis updated the admin system yet.

Try and disable the admin script see if that is the problem. If so we can nail it down to that(Which it most likely is because the error is showing too many requests).

I checked the value in the model and it’s on v1.5.8

While I check that version of Adonis, can you send all the while true loops that you perform in your scripts?

1 Like

Disabled the adonis scripts and problem still occurs.