Cam not changing

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Shaking cam

  2. What is the issue? No rotation

  3. What solutions have you tried so far? adding long wait

After that, you should include more details if you have any. Try to make your topic as descriptive as possible, so that it’s easier for people to help you!

while wait(.01) do
	A = workspace.Shake.Value
cam = workspace.CurrentCamera

Please do not ask people to write entire scripts or design entire systems for you. If you can’t answer the three questions above, you should probably pick a different category.

How do I fix it? What happened?

If the value of A is a decimal it won’t work, math.random only works with whole numbers.

Have you done this in a local script? When you do, you should set the CameraType to Scriptable. Your code should look something like this:

local camera = game.Workspace.Canera

A = workspace.Shake.Value

while true do
  camera.CameraType = enum.CameraType.Scriptable


it is a shake script. that would make the cam unmovable

how do i fix it? wgat can i do

What? You’re setting the camera’s CFrame. Setting it scriptable is required to having it be able to move around.

Mouse will not move it. unmovable

I’m super confused with what you’re getting at, please be specific

Using the mouse will not move it at all.

if that’s the case, set the camera variable to workspace.CurrentCamera and you can remove the CameraType. Forgot to add in a wait, you’ll need that in your while loop

Multiply the number by 100

A = workspace.Shake.Value
cam = workspace.CurrentCamera

function random()
	return math.random(-A,A)/100
while wait(.01) do
	cam.CFrame *=CFrame.Angles(random(),random(),random())

or another number, but changing the one that divides to the random number.
If you multiply it by 1000, it would be math.random(-A,A)/1000, the number of A must not have decimal places.

still broken. now what do i do

Can you show me what’s going on? Are there any errors too?

it prints a, but no errors. why?

Trying changing the CFrame in a Renderstepped in Runservice. So replace the whole loop with this:

local RunService = game:GetService(“RunService”)

   camera.CFrame *=CFrame.Angles(random(),random(),random())

nope same result. i dont know now