Camera bug on mobile

There has been a extremely annoying bug going on with the mobile version of Roblox.

While moving your camera, and opening the roblox menu at the same time, it completely bugs out your camera after you close the menu again.


The first open menu is showing the bug not present when not tapping anything on the screen except opening the menu. The second time the menu opens is me doing the bug. It’s better noticeable when replicated.

The only solution when the bug is occurring is to rejoin the game/server.



I reported this bug some month ago after getting complaints from players that their camera zooms out when they press some buttons (Opening the Roblox menu while touching the screen messes the camera).
I do hope this bug gets attention.


I experience the same bug happen without even touching the menu. It’s seemingly random to me, even on a default baseplate. Panning the camera ceases to work in congruence with the thumbsticks, keeping the camera stuck completely.


As a mobile user, This bug annoys me a bunch, the only ways I know to fix this is to sit in a VehicleSeat, or rejoin the game/experience/server.

This bug has been for a long time, and yet Roblox hasn’t fixed this, I hope they finally fix it because it annoys me.


This bug has been on Roblox for very long time. I’ve experienced this as well. My friends (as a mobile players) frustrated with this bug all the time while playing games. The solution we have is just to rejoin back into the game. Let’s hope this bug fixed really soon.


Not to necropost but, Ive found some games where this bug doesn’t work on.

Perhaps they have some fix that we dont know about?

They probably use their own custom camera scripts or use an older version without the issue.

1 Like

I still experience this issue as well, this bug has been going on for a long time at this point. I hate trying to rejoin a game because of the camera bug when I’m in the middle of something.


How this major issues on mobile still not fixed!?


When I play on mobile and accidentally press the Roblox menu button it messes my camera up and it’s so annoying because sometimes it happens during gameplay too. Then I have to play through the game with this messed up camera until I am able to save and exit.

1 Like

Same, the only solution is to leave or to use !rejoin (if it is in the game) but you lose your progress (the progress that is not saved, items you pick up for example) and if you were talking to someone or got something that is rare, this glitch occur (mostly because I missclick on menu)

All of this to say, this bug is annoying yea, i agree


Over the past few years, I have received several thousand reports about this from users who play my games. They do not understand that this is an issue with Roblox and not the game - I wouldn’t be surprised if this causes users to leave + dislike. Would love to see this fixed.

1 Like

Bump this up. This issue is still happening. I had someone in my server report this to me and suggested I used a hacky solution that just doesn’t make sense to me. This should be fixed. Perhaps it’s because Roblox doesn’t check for the last touched spot being untouched, so it continues to stick permanently.


The only way that seems to fix this is when you change the camera to focus on something else other than your character then make it camera go back to the character. Although the developer would have to provide a way to do that (Most don’t) and this should be fixed.

I find this extremely annoying and I hope this get’s fixed as soon as possible.

1 Like

This bug has been around for years and they still haven’t fixed it yet


Hi all!

For anyone experiencing this issue, please respond with what device you’re using and what place it occurs.


1 Like

I am experiencing this on multiple android mobile devices including phones and tablets and in all Roblox experiences. I reported this bug years ago and it still remains unpatched.

Devices I have experienced this on (although I believe it is extremely widespread)
Samsung Galaxy S9+
Samsung Galaxy Tab S5e

I’d be happy to provide more details in DMs in order to help get this fixed.

1 Like

Samsung Galaxy Note10 user here, I have experienced several times this bug.

1 Like