Camera:Interpolate() does not work in solo

Any LocalScripts calling Camera:Interpolate() do not work in studio’s play solo mode. It works fine in online, however.

Quick repro, which works in online mode:
Interpolate.rbxl (10.5 KB)


Having the same issue here, yesterday it worked fine.
EDIT: Windows 10 Home

I am not having this issue, Windows 10 Pro.

Having the exact same issue

Same issue here, Windows 10.

Same issue here, Windows 7

Windows 10, I noticed this in the intro for my game Heist; I’m glad this doesn’t affect online play, but it makes testing camera stuff difficult. (Resorting to setting coordinate frame in tests).

This is still an issue.

Yeah, still an issue, fix this please

We’re aware of this issue, and it is on our bug list.

1 Like

This should be fixed temporarily now (i.e. it may revert at a moment’s notice).

A permanent fix is being rolled out soon.

Thank you for your patience.


Same here. It works with two games that I’m helping a friend with but it doesn’t work in my game for some reason. I am on Windows 10

Interpolate has since been deprecated in favour of TweenService, which means that it’s no longer supported so this issue most likely won’t be addressed for you.

When did this happen? Because I did it to make a cutscene on my friend’s game and it worked purfectly fine.

This was deprecated a while ago so its on your friend for using it in game

No I’m the one who used it. My friend isn’t a scripter.

You shouldnt have used it then. Deprecated cleary states anytime something breaks in new work it wont be fixed since thats what deprecated means.