Can anyone help me fix this weird glitch?

Hello there! I’ve joined my game today, and this happened. Why is my place green all of a sudden? Please help, because I’ve worked too hard on this game. It wasn’t like that a few minutes ago.

Here’s what it looked like before:

Here’s a older copy which didn’t have anyone TC’ed to it:


What did it look like before? Was it different.


Hey, I posted it above. The coloration was that in the pic above. It just randomly happened when the place turned green. I didn’t even publish the place and it made the game turn green as well when me and someone else played it. I checked the lighting, nothing seemed off.


Which one is ingame and which one is in studio?

Are you working with a team or solo?

1 Like

Solo, indeed.
I did TC someone body they haven’t been on my studio yet because I haven’t told them.

Check everywhere for green. Check ambience too, located in lighting.

Were you using any plugins, or do you have any script that affects the color?

Both. Nobody has published my game since nobody was on there. And it’s both. As soon as green happened when I rejoined studio. It was in the game and I don’t think games publish themselves. And I have a friend that has never been on the studio before since he’s in college. And he’s sleeping since he lives in Philipines.

No ma’am. Nothing has been used to affect the color. It literally happened when my studio crashed then I rejoined, then it was all green. Then published in the game. And I have older copies and those are all green as well which has nobody TC’ed to.

I think this is the problem. You should try going to a older version, or recolor everything.

Is this set to a green like color?

Nothing in the lighting is green. I’ve checked. Everything is either white, grey, or black.

I have had this problem before.
What I did was uninstall Roblox Studio than re-install. Have you tried that yet??


Is there anything under lighting?

Nope, I will proceed in doing so as well. Thanks.

1 Like

Yes, but I disabled all of them and it didn’t fix the situation.

I can’t recolor due to the green fog still showing up at the moment.

Uninstall Roblox Studio and reinstall it like @StompyDonut426 said. If that doesn’t work, try going into a different version of the game. Do you happen to have your materials disabled? (Low Poly)