Cannot change group logo on specific groups

groups

#1

When trying to change the group logo, it will not save whatever image you try to upload. This seems to only be the case for some specific groups, as the logo that is being uploaded works just fine in other groups. Even when changing ownership, the new owner can’t upload any new logo whatsoever.

Here’s the group link:
https://www.roblox.com/Groups/Group.aspx?gid=3147068


Cant Change Group Icon
closed #2

This topic was automatically closed after 1 minute. New replies are no longer allowed.


opened #3

#4

Hello, for some reason I can’t change group icon.

Although not for every group, only specific one.

link:

I press “save”, it refreshes, and shows the same image.

I tried every image, they work on other groups of mine but not on that one.


#5

its been 12 days, still nothing is fixed.

i have to make important changes and the group icon is one of them


#6

I am experiencing this exact same issue since December of last year and it’s frustrating.

I have tried several different browsers and various different image resolutions to no avail.

Group:

It’s kind of silly that I’m stuck with a festive variation of my group’s logo for over a month now.


split this topic #7

A post was merged into an existing topic: Bump posts


#8

The issue is still present for me aswell.


#9

Has the image ever been moderated, since then you can’t reupload it.


#10

I checked, and I can upload the same image on other groups, so it wasnt moderated at all.

I think its a bug related to the new groups layout.