Can't access Roblox from browser, only from app

About 2 months ago, I’ve been faced with the problem in which Roblox games will not open through browser and the only alternative is playing through the app. Nobody likes the app, neither do I. I just went along with the, “it is what it is” mindset, but I can’t anymore. The browser feels more reliable, I can use plugins and it’s easier to traverse. It’s annoying to have the app open and the browser open and having to constantly switch through them both, while also accidentally trying to play through the browser all the time.

What happens is I press the play button, it starts the loading, then stops. It’s what the browser looks like when you usually open a game. Loading, then Roblox. But I don’t get the “then Roblox”, I get the “doesn’t work”. It’s start loading then nothing happens. Also, just to make sure everyone understand, I don’t mean the loading, when you load into the game, the loading before you start loading.

I have tried many solutions, but I forgot many (which I know doesn’t help), but I have tried disabling browser plugins, clearing browser cache, re-installing Roblox and a few more. Just because these have been my solutions, if you think I should redo these, please tell me, I probably have done one of my solutions wrong or messed up on the way.

Here’s a video of what happens on browser compared to the app. Anything that could help,

Hi there!

Chrome has a system that automatically blocks any modal dialog (pop-up) that is repetitive or considered ‘spam’;
There’re some extensions to block modal dialogs, do you recall installing any ‘anti-spam’ browser extension?

This is what I would do in your situation: (I just noticed this is mainly a structured compilation of what you’ve already tried :sweat_smile:… still try it, though)

  1. Log out from your account.
  2. Erase all the cookies and the storage cache from your browser. I highly recommend your erase them all, not just Roblox’s since interferences and malicious cross-origin setups might happen.
    (Clear cache & cookies - Google Help).
  3. Sign back in and try again.

If that doesn’t solved your problem, try re-installing your Roblox client (How Do I Reinstall the Roblox Software? – Roblox Support).
If it’s still not working, as a final attempt I would try with another browser.

Hope this helps! :four_leaf_clover:


Alright I’ve done everything, I have the Roblox player now, but no access through the browser. Anything else?

How frustrating!
Searching around other posts, I found this one… it may help you since the issue is similar:

Good luck!

1 Like

Wow thank you so much! I was so happy I yelled, “WHAT? YES!” You really saved me, thank you so much!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.