Can't change Role Names for Group

For this group, https://www.roblox.com/groups/group.aspx?gid=948872, I can’t change the role names. Each time I try I am greeted with a 500 error.
https://i.gyazo.com/e85aa50b183bd2941ae77631035b91d7.mp4
I thought maybe it would work the next day, however, even now it still doesn’t work.

Pretty much everyday I have to change the role names, since I use them to keep track of the team’s standings in the league.

Other groups where it is also occurring: https://www.roblox.com/groups/group.aspx?gid=944097 https://www.roblox.com/groups/group.aspx?gid=944099 https://www.roblox.com/groups/group.aspx?gid=2826068.

The only thing really in common with these groups are that their role names follow “CityName TeamName 0-0-0”. However, I can change a role name in a different group to “CityName TeamName 0-0-0” and it works fine.

1 Like

Do you recall the old name and the new name of the last role you changed before this started to happen?

The last role changes were:
“Washington Capitals 2-6-3” to “Washington Capitals 3-6-3”
and
“Ottawa Senators 3-8-0” to “Ottawa Senators 3-9-0”
both completed at the same time on on April 30th.

Anything past May 1st doesn’t work. Although I was able to change the “Staff” rank to “St” and back again to “Staff” just fine, but when I try to update one of the team’s ranking it errors again.

I just tried pasting “Washington Capitals 3-6-3” into a role set of a different group, and it succeeded, however, “Washington” was replaced with #'s. My guess is role names are now using the new filter and for some reason is just failing to save when it detects something needs to be hashed.

Would it be possible for you to attempt to replicate those roleset name changes once more on another group? It may be expensive (I would try but I have no group space).

I see three plausible scenarios here

  1. Those role name changes in particular have caused malformed data
  2. Those role name changes in combination with the other roles have caused malformed data
  3. It’s completely unrelated and I have no clue.

Since “Washington” is now permanently filtered. I tried it with “Capitals 3-6-3” to “Capitals 4-6-3” and I got this:

However, changing “Ottawa Senators 3-8-0” to “Ottawa Senators 3-9-0” worked fine.

Perhaps it has something to do with Washington Capitals (and its filtered state?)?

This at least narrowed it down.

Since @WebGL3D frequents the forum perhaps he could take a look or pass it on to someone? :open_mouth:

I think its more to do with the format “CityName TeamName Number-Number-Number” since only 2 of the 4 groups listed have the Washington Capitals in it, but they all contain roles were at least 6 of them are in this format.

Yes I meant the numbers and dashes included as well, but was too lazy to type them.

It probably is something to do with those since that’s not usually input you see in names.

I am experiencing this same issue with my group

2 Likes

same, it won’t let my group’s owner change role names, so he waited a few hours then went back, still nothing.