Can't get rid of Avatar Context Menu

Big problem that is driving me insane: I can’t get rid of this new Avatar Context Menu in Studio!
In the live version of the game, the menu isn’t there thankfully (though a bunch of other bugs just showed up out of nowhere so I’m really stressed right now) but in Studio whenever my cursor is on my own character and I click, this avatar context menu shows up for myself!
And by “Whenever my cursor is on my own character and I click” I mean WHEN IM IN FIRST PERSON MODE AND TRY TO FIRE MY GUN this menu shows up!

I’ve tried using
game:GetService(“StarterGui”):SetCore(“SetAvatarContextMenuEnabled”, false)
and it makes no difference.

It might be important to note that I’m not using a regular ROBLOX tool but rather am writing the code myself. So if this shouldn’t be happening when holding a tool it’s because I’m not.

This is driving me nuts! I’ve tried restarting Studio and everything and it’s still doing it and I don’t know why!
Please, someone, send help I’m pulling out all my hair trying to understand this.

15 Likes

I’m also experiencing this issue. None of my “tools” are actually “Tools” so essentially every time I click on someone (usually to fire a weapon at them) it pops up. Honestly a terrible feature (or at least terribly implemented). I’ll be disabling it across all my works once I discover how.

14 Likes

So that’s what this is. It’s driving me mad too. I hope they fix it soon because the problem is incredibly annoying.

1 Like

Video showing just how bad the issue is.

14 Likes

Strange that it doesn’t have Modal enabled. If I’m zoomed in and I click, then I have to zoom back out in order to close the window by pressing the x, or to interact with any of the buttons, which would of coursed be solved by enabling the Modal property. It’s also very weird that it’s triggered by your own character - you can’t add yourself as a friend or whisper to yourself, and can simply wave by typing /e wave. Simply removing this aspect of the context menu still presents problems for testing in solo servers, as I wouldn’t want to be using a weapon against a test player and having this menu pop up every time I try to combat them.

Edit: Didn’t realize that you could just click again or use W and S to navigate the buttons while zoomed. Still annoying, though.

I’d prefer this feature to go away entirely, rather than having a way to disable it, to be honest.

If it has to stay, though, I hope that these concerns are addressed;

  1. The context menu should automatically disable if you’re in first person.
  2. It should not be triggered by clicking your own character. There’s no point.
  3. The concerns about disabling this feature.

In my opinion, the context menu doesn’t really have a place in the PC version of Roblox. I could see it being maybe okay for mobile, but it just looks and feels really out of place otherwise.

5 Likes

To clarify any confusion, this is a bug – not intentional. The Avatar Context Menu is an opt-in feature, and is not intended to be enabled by default.

4 Likes

I like the idea of the feature, it’s good for roleplay games and such.
I’d rather it not be removed entirely.

5 Likes

I didn’t realize that the glitch was that the context menu was enabled by default. From this thread, it seemed to me that the glitch was in disabling the context menu. If it’s disabled by default then I have no problem with it, once this bug is addressed.

@Kampfkarren Maybe, but the UI looks kind of clunky to me - if I were making a role-playing game, I’d rather just completely make my own version of this feature. I do suppose it’d be an easy way for newer users to create quick interactive shortcuts.

Thankfully my game has a third-person over-the-shoulder mode so I am still able to test my game while I wait for a fix to this but boy am I annoyed by it.

Thank you for alerting us about this issue. Our engineering team is actively investigating and will be posting here soon with an update.

6 Likes

:+1:

If that’s the case is there a way to opt out as of this moment?

No, the ACM can’t be disabled right now in Studio unless you use custom corescripts.

I would like to note that not only will a menu open in Studio when you click yourself but also when you click other players when testing with multiple players controlled by multiple Studio windows.

1 Like

We have a fix in the pipe for this. I will update when I know it will ship.

2 Likes

Was able to turn this off in studio today, ACM should still work online though.

3 Likes

Yeah, I’ve noticed I stopped getting the menu when I click myself and other characters so I think it’s fixed.