Can't log into Roblox Studio

Hello! I went on Roblox studio to work on my game earlier today but came across a weird issue that is still occurring hours later after I found it.

Whenever I try to go on studio it tells me to log into my account, and when I do it keeps popping up with this error message:

I’ve tried redownloading the app and also tried the options the prompt gave me, but nothing worked regardless of how many times I’ve tried. I’ve also tried restarting my computer which didn’t work either.

I tried to see if I can find a solution online, but none of them really helped me out so this is my last option.

Any help is appreciated!

4 Likes

Try those steps:
Try Different Browser or Device
Disable Browser Extensions
Check Firewall and Antivirus Settings
Reset Roblox Studio Settings
Clear Cache and Cookies
Reset Roblox Studio Settings
Contact Roblox Support (if those dont work)

1 Like

I tried all these but they didn’t help. I tried one more thing which was to connect to a different internet which when I did actually fixed the issue and I no longer kept running into errors. The only problem now is that for some reason whenever I connect back to my regular internet, the problem comes back. It seems to be an issue from my internet. Any reason why this may be?

2 Likes

This effectively works. I wonder why the current, always used connection is having trouble communicating with Roblox servers suddenly? I wonder why switching networks makes it work! Just really curious.

1 Like

Encountered the similar issue. I tried changing my DNS and it immediately fixed it!

1 Like

I tried changing my DNS too, but it didn’t work for me. Are there any other possible solutions?

1 Like

Hello, Roblox is experiencing a technical issue, so once Roblox has fixed this problem, everything should work again. In the meantime, you can try all the techniques mentioned in this post to try to fix your issue. :slight_smile:

1 Like