Can't rotate camera

I can’t rotate my camera when holding right mouse anymore in studio?

https://gyazo.com/e39b1b4b71d5e079d05f6668ab663ff7

14 Likes

Do you mean right click or are you actually using to mouse’s?

1 Like

You appear to be in first person. Try zooming out.

You can’t go first person in studio???

Oh this is studio? Shouldn’t your camera turn without having to hold right click?

You hold right click to rotate the camera

1 Like

Try reopening studio. It might be a turn off and turn back on again issue

1 Like

I have tried this repeatedly

characters

1 Like

Try deleting and reinstalling studio.

I have done this twice and it keeps coming back. Not sure how it keeps happening.

This might sound silly, but do you have team create enabled?

Do you currently have any tools selected?

1 Like

No, it is disabled

characters characters

2 Likes

Is the only thing broken camera rotating? Can you select things(without touching workspace)?

1 Like

Everything works except rotating the camera. It’s genuinely annoying that this keeps happening.

2 Likes

That’s very interesting, I know this still sounds dumb but studio recently seems to have a lot of issues with team create disabled, could you try enabling it to see if it works?

5 Likes

That actually fixed it? Uh, roblox studio is so scuffed

3 Likes

Yeah, studio is extremely bugging, hopefully they fix it soon.

1 Like

I am having the same issue. I have tried toggling the “Team Create” button (from the View menu) and it made no difference.

Other projects don’t exhibit this issue.

2 Likes

I appear to have solved the issue, at least for me. In my Workspace I had a Camera whose CameraType was set to Scriptable. When I changed this to Custom, I was once again able to move the camera around by holding the right mouse button and moving the mouse.

60 Likes