Can't walk in Model

Hey devs

I made a model in Blender with places to go inside the model and i found something weird.

I can’t walk in the model, it seems like there is a invisible walls around it.
What should I do to fix it so I can go inside it?

1 Like

Turn the mesh’s “CanCollide” property off


I mean, then i can noclip thru the model and i want to just walk in places that are meant to walk in.

Just turn collisions off and allign the model with invisible bricks!

Yeah, that will work thanks !!!

1 Like

Not to plug, but I do actually have a plugin that might help with this, depending on the mesh.

It doesnt work… nothing happens

Is that all one mesh? If so turn can collide off. If it is model, select all parts inside and then can collide off.

Did you set it to “PresiceConvexDecomp” in the properties (there are two with similar names, one for rendering and another for collision, make sure the property: CollisionFidelity is set to PresiceConvexDecomposition.)

More on that here @CheeseMan_36 : New Studio Feature - CollisionFidelity.PreciseConvexDecomposition (Enabled Globally)

1 Like

Go to your studio then to to studio settings. At the bottom of the studio tab click on decomposition geometry. If it looks like a box then click on the mesh and change the collision fidelity to precise or hull. It depends on what you see.