Changing ColorSequence Crashes Studio


#1

I recently discovered a bug in Roblox Studio that causes the engine to crash. This is a reproducible bug caused by changing a color in the ColorSequence property of a Particle Emitter.

The bug can be reproduced by doing the following:
1.) Select ColorSequence on the Color property of a Particle Emitter
2.) Click the square next to “Color”
3.) Select a color and then close the Colors tab
4.) Click “Close” on the ColorSequence tab

Once these steps are followed, Roblox Studio crashes. This has happened every time I tried this.

I have included a .rbxl file below where the bug can be reproduced:
ColorSequence Bug.rbxl (13.0 KB)

Platform: Mac
OS: macOS High Sierra
It should also be noted that I have a perfect internet connection.


#2

Can confirm.

I came across this a few weeks ago late at night. Fell asleep and completely forgot to report it


#3

Yep, just tried it and it immediately crashed.

Although, I don’t know why the main colour sequence UI would still interactable while the colour select menu is open.


#4

I’ve experienced this issue before.


#5

I’m not on the team responsible for this UI, but I do have one question for you guys: is everyone here that can reproduce it running High Sierra?


#6

This is still an issue. Can we please have some confirmation that it is being looked into?

The game I’m currently developing requires me to edit the ColorSequence of many Particle Effects and I currently can’t do this without instantly crashing Studio.


#7

Maybe start by answering @0xBAADF00D’s question.


#8

If you take the time to read the initial post, I’ve clearly stated that I am running High Sierra.

I believe that question was directed at the other developers, who unfortunately don’t seem to be following this thread.


#9

@VineyardVine @Starception @HeadlessHorror When you guys reproduced the bug, were you running macOS High Sierra?


#10

I’ve experienced this issued on Windows 10 Desktop.


#11

Windows 10.


#12

Yes


#13

To answer your question 0xBAADF00D, myself and VineyardVine were running macOS High Sierra. HeadlessHorror and Starception were running Windows 10.


#14

Sorry for bumping this again but has there been any fixes for this? I’ve been running into this problem recently and I can confirm that studio is still crashing when selecting ColourSequence of a particle emitter. I’m currently running MacOS Mojave Version 10.14.


#15

I can confirm this is still an issue. I haven’t been able to edit ColorSequence for months because of it and the odd time I forget it’s still a problem, the subsequent crash has caused me to lose work.

I’ve tried fixing the problem by reinstalling Roblox Studio but unfortunately that doesn’t resolve the issue. I have also contacted Roblox staff multiple times to no avail. I’m hoping this can be fixed soon.


#16

Thanks for reporting! We will fix this soon.


#17

The bug is fixed if you restart studio.


#18

Thanks for helping us get this fixed, billlipeng!


#19

For those of you still encountering the bug and looking for an immediate fix, all you now have to do is ensure you have the latest version of Studio and restart the software.