Chat bubble coming from torso

I have an issue with my chat bubbles. I am using a newer version of the ROBLOX chat, that comes from something internal it seems, rather than a script in studio. In my old systems I was able to go into the coregui and edit the chat scripts to change where it comes from, color, etc.

In this version, it seems to be stuck coming from the torso, not the head. I’ve gone to the Chat service and tried editing the properties, along with search for scripts in the coregui, none of which has worked.

Does anyone know how to fix this so that chat bubbles come from the head rather than torso?

I think that if your custom character (the ant) works as a default R15 or R6, the Adornee Head will work normally.

If its a custom rig that doesnt work like a default one, you should change the LocalPlayerStudsOffset properties to something like 0, 1, -3, XYZ. Just play with the properties to do the offset where you want it.

1 Like

The default adornee for the chat bubble is the humanoid root part. Try changing it to the head.

Ensure that the rigging for the ants is named in the same configuration as a default Roblox rig. On top of that, make sure the Head is welded properly and is positioned to the apparent head location on the ant.

It seems the bubble chat is emanating from the HumanoidRootPart, which is defaulted when a Head doesn’t exist.

Hello. The issue is when I change these values it doesn’t affect it at all, it’s like it is being ran off of something else. The only thing that effects the actual chat seems to be when I check the LoadDefaultChat in chat service. Which just takes away all the chat.

Probably the setup of your rig is wrong. If it has a Head part the Adornee should normally work. As me and other devs stated the layout of your rig should be as the default roblox rig.

By Default the bubble chat comes from HumanoidRootPart even if it looks like its coming from the Head. If your rig has a Head just change it to Head.

I took an ant model from toolbox and converted it into a rig to test it:

I do that, but it doesn’t work it just stays in the HRP. My rig is setup properly, the head is named properly.