Chrome Pop-Up Dialog Always Persists

Ever since the recent Chrome updates, the dialog box ‘Open Roblox?’ keeps appearing when I want to play a game, and there is no checkmark to save settings given that I want to prevent that dialogue box from appearing again.

I’ve tried clearing history, cookies, and data. I’ve also reset all my Chrome settings to defaults as well as making an exception for pop-ups for Roblox only. None of these fixes work.

Another person posted this issue, albeit in the wrong category. https://devforum.roblox.com/t/chrome-pop-up-open-roblox-missing-check-mark-in-edge-canary/346815

8 Likes

Similar thread:

1 Like

This isn’t a roblox bug, it’s a chrome feature being removed. It’s been gone for over a month. The checkbox will not be re-added and if you want it back you’ll have to use an older version of chrome. If you google it, you’ll find the various threads and “bug” reports about it on chrome’s website.

4 Likes

Found a permanent solution.
What this method does is add a whitelist to the roblox player link on the website.
(Should also work with studio by replacing roblox-player with roblox-studio.)

  1. Open notepad

  2. Copy and paste this in:

Code:

Windows Registry Editor Version 5.00[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome\URLWhitelist]"1"="roblox-player://*"

  1. Click File -> Save As … (or press Ctrl+Shift+S). Change the file name so it ends with “.reg”, for example “name.reg”. Save it anywhere, for example on the desktop.

  2. Run the file you just saved by double clicking it. Click Yes, Yes, OK.

ROBLOX will now open without any prompts on Chrome.
Reload Chrome!

4 Likes

This did not work. Even after entering the code in Notepad and running it, the dialog persists.

If it helps I have made the .reg file already.
https://cdn.discordapp.com/attachments/674774337357742090/677559484360687646/roblox.reg

If you want roblox studio:

https://cdn.discordapp.com/attachments/674774337357742090/677560212898709509/robloxstudio.reg

4 Likes

Works! Thank you very much. If it doesn’t work for you, you will need to restart chrome entirely - which may include ending some tasks on task-manager.

1 Like

This unfortunately did not work for me. I appreciate the thread’s assistance though.

Works great! :+1:
It’s been months of confirming that I want to play/edit a game :tired_face:

Edit:
Nvm…

For some reason it doesn’t want to work on Roblox Player, but I can open Roblox Studio through browser just fine…

EDIT 2:
For some reason, it works now, even without the entry in the registry. I had to reinstall Studio, cause the mouse cursor stopped appearing, and now I can play games without any pop-ups :smiley:

1 Like

For a general solution, the way to bring back the checkbox for good (of course until google patches it) is to modify the registry with this:
image

and this for Mac users
image

These were taken from this reddit thread and have worked for me.

Check the reddit post for more information. I will not be liable for any system malfunctions. The registry is powerful tool! Always create a backup.

Full Posts:
image

image

1 Like