Closed, topic is closed

closed, topic is closed

Probably a very obvious question but can you confirm that you’ve actually changed this line to your animation ID in the script you used?
animateScript.climb.ClimbAnim.AnimationId = "rbxassetid://(whatever climb animation ID)"

You’d be surprised at how many small errors can pop up, just trying to ensure that even the slightest error hasn’t gone unnoticed.


Are you using your own animations? If not, then the ID won’t register.
Yeah, @Polyheximal has asked a simple, yet valid question. Mistakes like that do pop up quite frequently.

1 Like

Nah, I changed it to this ID: 2510230574 (Rthro climb) but it didn’t work. I’ve also tried changing it to = "rbxassetid://2510238627" but that didn’t work either. It just makes the animation default according to the (action).(Action)ID line of code. I haven’t tried it with a non character animation ID yet.

If I remember correctly, you had to own the animation for it to work (unless it’s changed recently).

EDIT: Not 100% sure if this applies to using animation packs from Roblox

1 Like

Oh really? If so, it’s not what the website said. Well that sucks… Since I can’t animate, anyway to bypass?

Try this:
Instead of rbxasset://

1 Like

Welp, that still didn’t work, same issue? I have no animation scripts that interfere with the animations.

Are there any errors in the output?

Try using a print statement, like

— piece of code
if thing == true then
1 Like

There are not any errors… Pretty weird tbh

Also, what sort of animation are you using? Climb, idle or?

1 Like

Oh, just realised I got this error: Humanoid is not a valid member of Workspace. Maybe the script is in the wrong place?

1 Like


You have set the humanoid within the character, right?

Also, what sort of animation are you using?

1 Like

Humanoid within the character? Sorry, all I did was what the link told me (make a script, put in ServerScriptService, put this code in:

local Players = game:GetService("Players")
local function onCharacterAdded(character)
    local humanoid = character:WaitForChild("Humanoid")
    for _, playingTracks in pairs(humanoid:GetPlayingAnimationTracks()) do
    local animateScript = character:WaitForChild("Animate")
    animateScript.(action).(Action)Anim.AnimationId = "rbxassetid://(whatever climb animation ID)"
local function onPlayerAdded(player)

but change this line accordingly:

animateScript.(action).(Action)Anim.AnimationId = "rbxassetid://(animation ID)"

This is a copy and paste script?

1 Like

I used the tutorial from the link above to make this script.

Edit: Just realised there’s another step, but it’s only for when there are 2 animations in 1. (E.g. idle.) But I don’t need both, just the Rthro idle loop would suffice.

Edit: And I just saw another, Playing Animations Directly. I now get what you mean. I think.

Ok, while I try find the problem, check this out it will give a rough idea on how to add custom animations.

Also, have you tried to change the default packages to Rthro via the game settings?

How would I do that? Also there’s one issue, I need the Walk and Run animations to just be Rthro walk. (There’s no running in my game, speed is capped at 10.) In Game Settings I see two options, Play Choice or Standard.

Send a full screenshot, then I can visually help.

1 Like