Constant 30-40FPS in Studio


#1

On this computer only (specs below), Studio runs at a constant 30-40FPS while in edit-mode, and 20~FPS while in play-mode.

Specs:
16GB RAM
Intel i7-8750H @ 2.20GHz (6 core, 12 thread, 9MB cache)
NVIDIA GeForce GTX 1060 6BGB VRAM
note: display is 144hz, Windows 10

32frame microprofile dump in edit-mode, running about 35-40 FPS:
microprofile-20180704-214005.html (573.8 KB)

32-frame microprofile dump in play-mode, running about 20 FPS:
microprofile-20180704-214402.html (1.4 MB)

Task Manager reports 21% CPU usage, 31% Memory usage

Any help is appreciated. I have tried fiddling with rendering settings in Studio, as well as changing CPU priority for Studio via Windows… I’ve also ensured Studio uses the GTX 1060 and not the onboard Intel 630 at all times.

My other PC with similiar specs runs at 60FPS constantly.


Studio Has Low Framerate
Studio has extreme lag when GraphicsMode is set to Automatic (Direct3D11 for me?)
#2

I’ve been having this issue sporadically (starting after an update ago?) but a restart of Studio seems to fix it.


#3

I have been experiencing this issue for weeks, regardless of how many times I restart/reinstall Studio, or restart my PC.


#4

Related possibly


#5

I noticed this when I swapped back from Discrete (GTX 1070 laptop only) to NVIDIA Optimus (GTX 1070 + HD 530) while using OpenGL. Using DirectX 11, I did notice a drop in frame rate between my primary (Intel controlled) and secondary/thirdary (NVIDIA controlled) displays, but it was a difference of like 120 and 100 FPS in Jailbreak. I have a feeling this affects Optimisms setups, rather than just NVIDIA GPUs.


#6

Your post gave me the idea to try alternative Graphics Modes. Changed Graphics Mode
from Automatic to
OpenGL… 20fps in edit mode.
Direct3D11, 30-40fps in edit mode.
Direct3D9, 60 GLORIOUS frames per second in edit mode and play mode!

Microprofiler calmed down, too.

Very strange that my DX12 equipped PC performs better on DX9 rendering vs dx11, no?

edit:

here’s a new 32-frame microprofiler dump in edit-mode while running at 60-fps, in-case somebody wants it. microprofile-20180704-222117.html (533.4 KB)


#7

Roblox doesn’t code for DirectX 12 due to the existence of DirectX 11. DirectX 9 and 11 shouldn’t have a major difference. If your laptop supports it, can you see what happens with Discrete mode enabled (Clevo/Sager does, not sure about MSI, ASUS, or Gigabyte)?


#8

How do I go about enabling Discrete mode?


#9

I am going to DM you about this because this typically a brand specific and series specific thing.

Edit: Ended up not being a feature in favor of a much higher battery life. The laptop in question is an MSI GS65.


#10

So, I would like to be able to run studio with Direct3D11 at a decent FPS, instead of forcing D9. Does anybody have any more suggestions?


Consistently getting low FPS in Studio but 60fps in Roblox player
#11

If you haven’t done it already, check what GPU Studio is assigned under. I recently got slow FPS in Studio but it was set to my integrated Graphics instead of my GPU.
I found this out because in the Task-Manager it said Studio was assigned under GPU 0 (Which is Intel integrated), instead of the normal GPU 1 (My Radeon RX570 GPU).

Or, don’t do it if you’ve already checked. But idk :woman_shrugging:


#12

This randomly started happening to me too. To quote myself:

Since like Monday my studio has had really bad framerate.

It seems to get worse whenever I start messing around in the explorer, like selecting objects and collapsing it and stuff, but it also gets worse whenever I insert stuff through the advanced object menu or the toolbox. Using the building tools also doesn’t help.

This happens in every single place I open, even a blank baseplate. It’s really slowing me down so help would be appreciated.

Running Windows 10, but I can’t tell you all my specs because I am away from my computer. I disabled all my plugins so they aren’t the problem.


#13

Does switching the graphic setting to dx9 perform better?


#14

Yeah, thanks. It is weird how it just randomly started happening though.


#15

Did your graphics driver recently have an update? there has been multiple cases of this all stemming from the laptop version of a gtx 1060 gpu


#16

Nah, not that I know of anyway. I have an Alienware tower and not a laptop, too. Weird.


#17

So this solved my issue but now everything looks pixelated in studio (It looks way worse in reality):

I hope the actual bug is fixed or something because this will annoy me a lot while working.


#18

Agreed dx9 looks like crap… its very annoying.