Conveyor belt only works with thicker parts?

Has anyone run into the problem where their conveyor belts don’t work if the part is too skinny and only if it bigger? I tried by changing the velocity and by coding it and it is the same for both. Anyone got a solution for this issue or is it just something I’ll have to deal with?

Conveyor doesn’t move with the part below because it is too skinny

Id suggest putting this into #help-and-feedback:building-support as that makes more sense.

1 Like

I don’t know about velocity that much, but I assume that the strength of velocity is also affected by the part’s Mass. So try setting the Massless property to true and see if that works.

Also, if that doesn’t fix it try putting an invisible part that has a bigger size inside of the conveyer and make it act as the conveyer

The massless property did not affect it for me. I believe you are correct that it does have to do with the mass. I tried setting custom physical properties and cranked the density up and it seems to be working as a conveyor. This ‘issue’ also breaks ROBLOX’s Obby template.

Yeah I had to shrink my model that I wanted to be moved in order for it to work. It definitely has something to do with mass but I’m not sure how to control it.