Copy-Paste breaking across the operating system (Windows 10)

If you’re in game, and you try to paste an image into the chat or a text box (Lightshot or something) then it will break the copy-paste function across your entire PC until roblox is closed. This goes for other apps too, like notepad and stuff. Even when you try to copy text again, the text won’t copy properly. Pretty much all clipboard functions are disabled for all programs temporarily.

35 Likes

Some more info: I was able to replicate this in any in-game text box. It seems that it only works in-game, and not in Play Solo in Studio. Paint returns this error when attempting to paste the image.
image

3 Likes

Honestly I couldn’t even get that far. If I right click to copy or paste, the button is greyed out. Same deal with hotkeys, they just don’t work.

7 Likes

I’m not sure if this is a Roblox related bug or not however there is a fix. Open your command prompt and run cmd /c “echo off | clip”
This will clear your clipboard and reset it.

Edit: This is a bug caused when you try to paste content into Roblox’s chat that it doesn’t support. You can fix this by typing something into the Roblox chat, selecting it, copying it, deleting it, then pasting it back in. You can also use the solution above if that doesn’t work (requires closing Roblox).

18 Likes

I tried to paste the image back into ShareX and received this.

ShareX_2019-07-07_11-26-08

Looking into the documentation for System.Windows.Forms.Clipboard.GetDataObject():

https://docs.microsoft.com/en-us/dotnet/api/system.windows.forms.clipboard.getdataobject?view=netframework-4.8#System_Windows_Forms_Clipboard_GetDataObject

This method attempts to get the data ten times in 100-millisecond intervals, and throws an ExternalException if all attempts are unsuccessful.

Hence the call to GetDataObject that takes retry parameters.
This method throws an ExternalException if:

The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.


Also while using clipboard viewing software, when the issue is triggered all of the the "Handle Types" reported by the program become Null, which is presumably the result of GetClipboardData failing.

image

image


Is Roblox hogging the clipboard when it tries to get text from the clipboard and fails?

This happens when you try to paste into a textbox in Roblox and your clipboard does not contain CF_TEXT.

Maybe somehow Roblox isn’t calling CloseClipboard when something goes wrong?

8 Likes

I found a fix(this bug still happens)
so what you do you highlight something in a text box (or chat), highlight it and copy it (control + A or something)
then your copy and paste is fixed no need to close Roblox

8 Likes

This still needs fixing, it’s annoying me when I’m debugging my games, or messaging people. The only solution I’ve found so far, is to quit and relaunch Roblox. It has been a major bug for at least a few years now.

Here are some scenarios where this becomes an annoyance:
Debugging, sending screenshots, sending messages with copy paste, pasting something into Roblox (like a sound ID or line of code into the console), and so on.
I know people who think this isn’t an issue with Roblox but an issue with their system. So as a “fix” they restart their system, which is very inefficient. Again, this issue has existed for a number of years, and I’m surprised to only see a handful of people complain about it.

1 Like

While roblox still hasn’t officially fixed this, you can use the method I marked as a solution to help your sanity a little bit. It’s worked for me, so good luck I hope it works for you as well.

Bumping this because it still isn’t fixed. It’s annoying that I need to use a workaround every time I paste an image in by accident.

I also recommend removing the solution, a temporary workaround is no fix to a common issue, and it makes it seem like the bug is fixed, which it isn’t.

5 Likes

Bumping this because it is still an issue. We only have workarounds, but this shouldn’t be happening in the first place.

7 Likes

Replying again to point out that this is still an issue that regularly effects me

5 Likes

I definitely remember this happening constantly to me. I never had any issues anymore, probably because I’m not pasting anything anywhere else, but I 100% remember having Roblox break my copy and paste.

Bump.

This is still an issue and its so annoying, it pretty much affects me every week. Running @echo off | clip every time to fix it is getting monotonous at this point.

1 Like

I made a batch file to run it automatically, absolutely needs fixing, I’ve been using this workaround for so long.
It would also be good to know if it’s a Windows or Roblox issue, I’ve searched for people having this issue outside of the devforums and it absolutely exists, but it’d be good to know if Roblox… exacerbates it?

1 Like

With my game, I use keybinds ctrl c and ctrl v for a specific action. It still breaks the copy and paste even if I haven’t actually copied anything, this issue still exists.

1 Like

Happened to me a few days ago, and has come up very occasionally since 2019.

I wonder if this is at all related to the copy/paste issue studio has been having forever, where you tell windows to copy something in studio but it fails to copy anything sometimes.

1 Like