CoreGui Manipulation

Hey devs! :cool:

I’ve been playing a lot of disturbing games lately to get inspiration for the new horror game I’m developing, and I stumbled upon a cool CoreGui glitch!

I know that aside from using the StarterGui:SetCoreEnabled() function, it’s nearly impossible to manipulate or even access the CoreGui itself, as it’s only been accomplished a few times. But the following game appears to have actually achieved CoreGui manipulation, or at least overriding the CoreGui, as they have managed to disable every button on the escape menu entirely!

Here is the game that I found this on:

Here is the recording of the glitch:

As you can see, the CoreGui appears to be overridden by some big grey rectangle placed in the center of the screen… I don’t know how this is possible.

I have searched many forum posts on CoreGui manipulation, and none of them seem to have actually accomplished it. I even tried checking the output while I was inside of the game, and I have not yet discovered anything important. I would personally love to have this kind of code on hand for my horror game, so let me know if you have any ideas on overriding or manipulating the CoreGui!

2 Likes

I’m almost certain this would be against the rules, so I wouldn’t recommend trying it. Also, I took a look, and Esc->L->Enter still works. So it’d be ineffective (except against mobile players) and possibly rulebreaking. Plus, I don’t think your players would exactly approve of it if they couldn’t leave a horror game when they’re scared.

Firstly I don’t believe it’s against the rules because I have not yet discovered any forum posts that agree it would be, and I have not found anything in the Terms against it myself.

Secondly, I am only interested in manipulating the CoreGui for my game, and I would like to know how this is possible. I would not abuse the feature or use it to trap players out of their will, I just think it’s an awesome glitch/hack that would be cool to feature in my horror game.

I also know that this does not completely trap players inside of the game, because you can always press Alt + F4 to immediately exit whenever you need to. It is simply just a cool glitch that would make the game more scary and appreciated.

Well, the issue is, trying to parent something to CoreGui results in this:


Both LocalScripts and normal Scripts have this problem. You’d somehow have to get the permissions, which the methods to obtain aren’t likely to be shared by the creators (because if it became public, it’d probably get patched).

However, if you’re up to the challenge to try to figure it out, here’s the path to the Esc Gui:
CoreGui.RobloxGui.SettingsShield.SettingsShield.MenuContainer

1 Like


I already found a way to do so.

Also if you notice something, you can still see the blur of the CoreGui

Yeah I’m starting to think this is against the rules because if you notice that the frame is over the CoreGui and if you guys remember the incidents that happened a few months ago when that YouTuber lost 1 million robux… because someone actually found a way to make the CoreGui invisible (and still functioning) or make a button OVER it.

You mean you found a way to access the CoreGui menu?

Well I’ll experiment with this for myself. And I do agree with you, it would be best that this glitch doesn’t actually get revealed to public as it would likely get patched after that. Thanks for the info though, I appreciate it. :+1:

The owner of this thread requested that this message be redacted.

2 Likes

Wow! I’m super impressed you actually solved this! Thanks so much for your help. You’re a genius. :slight_smile:

1 Like

hey any way u think i could do this?

how did you get this done? please help im having the same issue