CSG Union Returning with Error -11:

Reproduction Steps

  1. Go to Roblox Studio, select/create your baseplate, and insert parts;
  2. As having two parts, union them and duplicate further (for my case, 13 was the amount I did);
  3. Duplicate the 13 union parts four times and move in a bit far distance;
  4. Go to MODEL, and select Union.

Expected Behavior

I expected that it could union all of the selected parts to make it more simple and efficient for my construction using it.

Actual Behavior

Once pressing Union, the screen loads and in around 0.5-1 seconds, it prints me the information that CSG is printing the error code -11.


Issue Area: Studio
Issue Type: Display
Impact: Moderate
Frequency: Often
Date First Experienced: 2022-09-27 00:22:00 (UTC-3)
Date Last Experienced: 2022-09-28 00:13:20 (UTC-3)


We were able to reproduce your issue. We’ve filed a ticket to our internal database, and we’ll follow up when we have an update!

The model affected was attached to the internal ticket, at the developer’s privacy request!

Thanks for the report!


having this error with the latest studio update, just trying to union together around 15 parts at once.

Hi Wither, I’m trying to reproduce this issue and having difficulty getting the error.

You mentioned on the other thread that it was happening on parts that were created on a previous release. If you create parts on this release, do they have the same problem? Do you have a file that you could share that has the problem?


1 Like

Hello, I’m having this same issue with a script and it seems to be consistent with and without the CSG V3 beta enabled.

When I tested using the select tool and tried to union them there, studio instantly crashed. Though I’m pretty sure that’s an unrelated issue and not my main problem.

PartGenerationTest.rbxl (37.4 KB)

1 Like

Thanks DrewDude500, super helpful. We’ll take a look


I had error code -8, but when i disable CSG V3 beta, then it worked but 2 parts disappeared

I really don’t know how it happened

Hey @L3Norm, I have returned to this topic to report that I have reencountered the bug… As having two Union parts with 112 parts each in my experience “The Fallen”, I decided to merge them and in the LogService (the property where it sends texts at the Output tab), it printed the error -11:

Union 1 & 2 - CGS Error -11.rbxm

same with me here

(edit : its just bunch of corner wedges here)

1 Like

cc: @L3Norm

Same here i was removing the inside of spheres with negate and union then when i decided to turn it into a single sphere i got this error

Thanks for the test file, super helpful