1 Like

This often happens with lights. I would suggest using beams to create the lighting look (some info here: How do I create a light beam)

1 Like

If this doesn’t occur with max/high graphics, then it’s just Roblox’s backend code allowing for better performance while dealing with lights.

If you are using future lighting, try to disable CastShadow on parts right around where the light is, it will eliminate some of this effect.

With future u have to readjust the properties of the lights, so range and brightness accordingly.

With future lighting, a little goes a long way. Turn the brightness DOWNNNN.

Wanna brighten up an area? Increase the angle and range of the light.
Also, make sure to disable the CastShadow property on things in the immediate area of a light(such as a light fixture, part of a wall, etc). This might be harder to do on a train, but that’ll make your light look a lot better.

Make sure to use the different lights correctly. A headlight? Use a spot light. A longer ceiling light? Use a surface light. A light coming out of a light bulb? A point light.
That’s what I’d personally use, but you do do!

1 Like

Are you sure that you’re using the right kind of lights? Could you show an example and show an image of the light selected in Studio?