Device Emulation + StreamingEnabled breaks Terrain LoD

When using device emulation with StreamingEnabled, the level of detail on terrain completely breaks and I believe just defaults to the lowest level of detail. That does not change no matter where you are on the map.

Without Device Emulation

With Device Emulation (Demonstration)

Using device emulation (with StreamingEnabled):

Even manually setting the graphics quality using the escape menu does not fix it. Going closer to that bit of terrain doesn’t change it either, which leads to funny issues like this:



Beautiful.

System Information

Intel i5 4690 CPU @ 3.5GHz, 20 GB RAM, NVidia GeForce GTX 1060 GPU.

Reproduction

Quite simple. Use a place with Terrain + ensure Workspace.StreamingEnabled is true, then use Device Emulation. Terrain LoD rendering completely breaks.

The difference seems to be with Device Emulation, as without it the terrain behaves normally.

11 Likes

Thanks for the post! I have reproduced this and am investigating.

4 Likes

@Vorlias Can you try increasing the value of minimum radius slightly? I suspect it is streaming out all the way down to the minimum radius, and if you have it set to the default (64) that can cause rendering issues with the terrain LOD.

4 Likes

By slightly I mean 128 or 256.

1 Like

For now, it seems this issue is avoided with a StreamingMinRadius of 192+

1 Like

This happens on any emulated device regardless of what is being streamed, my issue can be found here and I go into detail about what is happening - I have also gotten other people to repo as well (my post as the repo steps in it). This seems to be an issue with streaming enabled and emulated devices in general.

This is a big issue for devices with low memory. The LOD refused to go away even when the players are nearby. This is still happening, having a higher min radius increase crash rate on mobile for some reason.

1 Like