Disable changing camera mode

Hello, I’ve been searching for a while now and still can’t find a solution.
So far, I managed to change the Shift Lock Switch and Movement Mode to “Set by Developer” but I can’t seem to find the setting for Camera Mode.
I’ve tried the properties “CameraMode”, “DevComputerCameraMode”, “DevTouchCameraMode” and they don’t seem to be changing it.


The property is under StarterPlayer as DevComputerCameraMovementMode. The mobile property has the same name, except change Computer to Touch.

Dev[InputMethod]MovementMode pertains to the control scheme. CameraMode pertains to the camera perspective. CameraMovementMode pertains to how the camera’s movement behaves.


Im actually currently having the same issue:

Ive changed both to classic, yet the user can still change it if he or she pleases

I dont know if this roblox mechanic is broken or not, but I’ve also looked on the wiki and attempted to change it via scripting but I get this error:


If anyone has a solution to this, that would be great, cuz currentrly if the player plays with this, it breaks my cutscenes in game!


Interesting - I tried reproducing this issue and I received it, though I can’t yet confirm whether this is a bug or not. I started a Play Solo session in Roblox Studio, flipping DevComputerCameraMovementMode from Classic to another option and back worked out.

The error, however, I did not receive. I didn’t change it from a script so that might be different for my scenario.

I’ll be asking any sort of roblox staff soon, because it’s seriously breaking my game lmao

If this is a reproducible bug that you can trace, do file a bug report regarding it in #platform-feedback:engine-bugs. The best way to make this issue known is by raising it on the proper categories where engineers read reports, over “contacting any sort of staff” (not all of them are equipped to handle issues like this).

oh awesome, thanks I totally didn’t even know we had a section like that