Disable player bounce from the ground

Disable player bounce

Hey,

i hope you can give me some ideas how I can prevent the bounce.

The problem
Players who fall on a part bounce off the ground. I do not want this to happen. The velocity in x- and z-direction of the player should not be changed, so that there is still a smooth movement.
robloxapp-20200928-2131180 (1)

My attempt so far
In a LocalScript I run each heartbeat one raycast from the player down. If the player is just above the ground, the velocity of the primary part in y-direction is set to 0.
Unfortunately this solution only works about every other time.

For my 2D-platform game it is essential that this behaviour does not occur anymore.

Friendly greetrings
Urulad

If you’re using a base part, go enable CustomPhysicalProperties and set ElasticityWeight to 100.

1 Like

Thanks @TOP_Crundee123, that was the solution. I didn’t have the Custom Propertys on the radar. This is an elegant solution, thank you very much.

My values
density = 0.7
friction = 0.3
elasticity = 0
frictionWeight = 1
elasticityWeight = 100