Dragger QoL Improvements [Beta]

After this is out of BETA, could this become an optional setting? I’m not too much of a fan of it.

I’m just going to disable it on the Beta Features settings, but I’m still gonna say that this stuff is actually overwhelming. So much clutter. I’m just trying to move a from one point to another and I don’t need to see all of this.

1 Like

Not really a huge fan of this feature to be honest, could this be an optional setting where we can disable/enable it?

1 Like

its a beta feature so you can just disable it in the beta feature menu if you have already enabled it

but its not enabled on default


Indeed :sweat_smile:

I expect it to take up to 6 months of tweaks before we feel ready to release this out of beta, that’s how long the last dragger update took.


This is a follow up of my original post, it’ll be me speaking on the little quirks that bug me with the beta.

  • Shift to Snap Harms Workflow

Right off the bat, something I cannot seem to adjust to is Shift to enable snapping. I find myself often resizing parts, and pressing shift to slow down my camera and move alongside the part I’m resizing. With this, I’m now notorious to have parts be partially off size because of the fact I enabled this snapping behavior by accident.

I’m personally not a fairly big fan of the snapping, I could imagine others would benefit from it, but I just don’t. I work with increments all the time, so snapping isn’t fairly necessary for me. It negates against my work flow, and I’m hoping to in the future have an option to disable or re-hotkey the snapping behavior.

  • Excessive Transform Lag

This is an issue that happens fairly often, but it seems to be if I move a large amount of instances in one go, with the transform tool, my Studio window will freeze and nothing will properly move.

That’s all I’ve got for now, thanks!


I can say that this has happened to me too. I’ve accidently resized and moved parts imprecisely due to that.

Another thing I’ve noticed is that when I move a model with some of its descendants selected, I get unexpected results. An example can be seen below:

Normally, when you drag a model one stud upwards and back downwards one stud, you’d expect everything to be in the same location when you started. However, this is not the case. It looks like the selected parts underneath the selected model are doing some kind of snapping.

When I do the same action without the model selected, the expected behavior happens. The same goes for when just the model is selected and none of its descendants. In other words, this snapping behavior only happens when I have both the model and the descendants selected.

This situation comes up a lot for me and it has caused me to accidently move things that I did not expect to move.


I was wondering if it’s possible to add a feature where you can create reference lines & be able to snap to it.

The idea is inspired by Plasticity’s 3d modeling software that I use and it’s so much faster aligning things.
Here’s a video showing how it works.

refs: Sketching Essentials - Plasticity Manual

This can be another way of aligning parts together without dragging the part near other parts just to create a “Reference Line”. The reference lines will also have the functionality of grid-snapping and also be able to position pivot point on the reference line.

The other suggestion I wanted to have is to be able to resize multiple parts on their normalIds and not just uniformly scale this can probably have the option to enable or disable or any other shortcut that can activate it.

This was already possible by F3X’s Tool or plugin waaaayy back the old days of having a build server. I was wondering why it hasn’t still implemented yet in studio. It’s so much faster!

1 Like

The way dragging objects works for cylindrical / spherical objects is very awkward. Here I have a union that is aligned with a cylinder. When I try to drag it back into place it doesn’t quite align, even though the cylinder is placed on an integer grid with non-decimal dimensions.

I can see why the new behavior would intuitively make sense, but aligning this union with the cylinder is a lot more convenient with the beta turned off. I ran into a similar situation earlier today as well where I tried placing a cylinder on the corner of a surface and I was struggling there too. It took me a couple minutes to figure out why I couldn’t align it.

I also ran into the problem some other people have mentioned before where dragging an object along the surface of a mesh would send the object billions of studs down into the void.


Yes, this is just an obvious miss and will be changed. For now you can drag by the pivot instead in that scenario.


It has been making me instantly crash every time I move a large part.

1 Like

Why did i just find out about this today bruh… This is a game changer…

1 Like

Hey, just a small issue i found. Whenever you try resizing bones it’ll permanently break the Scale draggers and will require to reload studio/the place in order to get them working again.

1 Like

This is a good feature, and I was using it for bigger builds. However, for small builds like tools. It’s a real pain since it miss aligns everything. Really annoying when that happens.

Got any particular cases you’d like to share?

The snapping behavior should not be that different than before with grid snap enabled unless you’re working with a lot of MeshParts, and I’d expect the snapping to be improved with those.

I’m working with regular parts. Recently I encountered an issue with the aligning when trying to make a keycard tool. When trying to align 1 small part to the side of another small part it would have a small gap between them. After many tries the issue wouldn’t go away so I just used an alignment plugin to do the job.

In short when trying to move the part to align it to another part it stopped at a circle on a white line. Which left a small gap between the two parts.

The last circle on the right is where I stop, and for some reason there’s a gap. (Very last I spread them apart so you could see the last circle.)

The video explains my frustrations. Doing this all day sucks. I want easy alternative.

These tools are great, however they have major flaws. Most notably grab points on wedges & cylinders being awful.
The only other issue I have with the tools is that they still don’t solve the issue of parts being off by ~0.001 studs when building even when you have the snap set to values way above that.
Besides those two things, they are an improvement.

Hey! I know a lot of people who would really love to see the functionality in the video i’ve attached brought over to the studio tools, it’s honestly kind of a shame it hasn’t been like this since the start. I’m really happy with all of the changes thus far though :D. Oh and make it so we can add our own meshes / parts in the part drop down please :3