Empty screen after new assets uploaded to Roblox

When uploading assets to Roblox, the screen that used to show me a progress bar and a link to my asset is empty now, leading developers to believe that their assets weren’t properly updated.

This was introduced with today’s update I believe as I was using Studio ~12 hours ago and didn’t encounter it then. I’m using Studio version 0.431.0.404520. This happens 100% of the time.

Here’s what would normally pop up.

22:44:42.951 - Plugin_Toolbox.rbxm.Toolbox.Libs.Rodux.NoYield:26: Plugin_Toolbox.rbxm.Toolbox.Core.Components.AssetConfiguration.AssetUpload:139: attempt to index nil with 'AssetConfigName'
22:44:42.952 - Plugin_Toolbox.rbxm.Toolbox.Core.Components.AssetConfiguration.AssetUpload:139 function mapStateToProps
22:44:42.952 - Plugin_Toolbox.rbxm.Toolbox.Libs.RoactRodux.connect:106 function init
22:44:42.953 - Plugin_Toolbox.rbxm.Toolbox.Libs.Roact.Component:282 function __mount
22:44:42.953 - Plugin_Toolbox.rbxm.Toolbox.Libs.Roact.createReconciler:317 function mountVirtualNode
22:44:42.953 - Plugin_Toolbox.rbxm.Toolbox.Libs.Roact.createReconciler:88 function updateChildren
22:44:42.954 - Plugin_Toolbox.rbxm.Toolbox.Libs.Roact.createReconciler:100 function updateVirtualNodeWithChildren
22:44:42.954 - Plugin_Toolbox.rbxm.Toolbox.Libs.Roact.RobloxRenderer:273 function updateHostNode
22:44:42.954 - Plugin_Toolbox.rbxm.Toolbox.Libs.Roact.createReconciler:215 function updateVirtualNode
22:44:42.955 - Plugin_Toolbox.rbxm.Toolbox.Libs.Roact.createReconciler:67 function updateChildren
22:44:42.955 - Plugin_Toolbox.rbxm.Toolbox.Libs.Roact.createReconciler:110 function updateVirtualNodeWithRenderResult
22:44:42.955 - Plugin_Toolbox.rbxm.Toolbox.Libs.Roact.Component:455 function __resolveUpdate
22:44:42.955 - Plugin_Toolbox.rbxm.Toolbox.Libs.Roact.Component:393 function __update
22:44:42.956 - Plugin_Toolbox.rbxm.Toolbox.Libs.Roact.createReconciler:219 function updateVirtualNode
22:44:42.956 - Plugin_Toolbox.rbxm.Toolbox.Libs.Roact.createReconciler:67 function updateChildren
22:44:42.956 - Plugin_Toolbox.rbxm.Toolbox.Libs.Roact.createReconciler:110 function updateVirtualNodeWithRenderResult
22:44:42.957 - Plugin_Toolbox.rbxm.Toolbox.Libs.Roact.Component:455 function __resolveUpdate
22:44:42.957 - Plugin_Toolbox.rbxm.Toolbox.Libs.Roact.Component:393 function __update
22:44:42.957 - Plugin_Toolbox.rbxm.Toolbox.Libs.Roact.Component:161 function setState
22:44:42.958 - Plugin_Toolbox.rbxm.Toolbox.Libs.RoactRodux.connect:162
22:44:42.958 - Plugin_Toolbox.rbxm.Toolbox.Libs.Rodux.Signal:70 function fire
22:44:42.958 - Plugin_Toolbox.rbxm.Toolbox.Libs.Rodux.Store:125
22:44:42.959 - 
22:44:42.959 - Stack Begin
22:44:42.961 - Script 'Plugin_Toolbox.rbxm.Toolbox.Libs.Rodux.NoYield', Line 13 - function resultHandler
22:44:42.962 - Script 'Plugin_Toolbox.rbxm.Toolbox.Libs.Rodux.NoYield', Line 26 - function NoYield
22:44:42.962 - Script 'Plugin_Toolbox.rbxm.Toolbox.Libs.Rodux.Store', Line 124 - function flush
22:44:42.962 - Script 'Plugin_Toolbox.rbxm.Toolbox.Libs.Rodux.Store', Line 46
22:44:42.963 - Stack End

Oof, sorry about that! Our engineers are working on a fix which should make next week’s release.

In the meantime, this only happens if you save without making any changes. If you modify the title/description/etc in any way, you should be able to save the asset.


My thread on this topic was locked, but I would like to point out that this bug has made it impossible to upload any new animations to a group.

Please make a thread dedicated to being unable to select groups as owners separate from the publishing report you filed earlier.

It’s working as expected now.

1 Like

I just started having this issue again yesterday with the animation editor.


Same I cannot upload any animations at all either, it gives me the exact same error.


Just to get clarification, you are seeing the same error log that the OP posted in your output window, and also getting a blank screen after trying to upload the asset?

1 Like

I fixed it. Not sure if it had to do with the name but after uploading it under a different name it works fine.

1 Like

Yes its the same exact issue and same log in output, I was trying to upload a animation for my upcoming game and it displayed practically the same error, maybe I can try again and hope that it fixed itself idk.

The issue is still occurring but it only happens when you use a word that roblox finds inappropriate. When uploading an animation there is no way of telling if a word is inappropriate or not so maybe add that in.


This worked for me too! Was getting the same issue as OP, but after changing the name it worked fine.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.