Entire game corruption

I’m gonna make this fast and snappy because this has really impacted me as a developer.

As seen below, my online place has been corrupted with the following error:
SerializerPugi::deserializelmpl ill-formed XML.

Place link: R2D: Classic Edition [Debug]
I really can’t lose this place as I’ve spent way too long and several hours working on this game.

There’s absolutely nothing I can think of that would have caused this. I was using studio this morning, saved my place to Roblox and then logged off. When I came back on this afternoon, the place was corrupted and the message began to appear.

Edit: I get this error when trying to open the place from the website:
HttpError: curl61 Unrecognized or bad HTTP Content or Transfer-Encoding

7 Likes

Sadly, I don’t have much to add here. But there is times I’m unable to access my game for several minutes and have to restart studio multiple times while getting the Contact customer service message.

This usually happens when the map was too big and studio timed out while downloading the place. But now the Icon goes blank as if its being moderated, and the studio hangs while opening the game. Its pretty weird and sounds like the same issue you’re experiencing. So I thought I’d add my 12 cents. (yes 12… not 2)

2 Likes

Have you tried reverting the place version manually?

1 Like

Hey, you’re not alone on this one. Last night we experienced that exact same thing whilst we were trying to push an update out. It resulted in us having to revert to a previous version and all of our work was lost.

image
Place link: King’s Landing [REMASTERED]

We couldn’t enter our place in studio and even worse was that players couldn’t connect to the place at all.
It’s very demoralising when you spend hours on updates and this occurs and you are forced to revert if you don’t have a backup.

Lots of people are reporting that they are experiencing this issue:


2 Likes

I had to revert to around three updates ago which is a MASSIVE blow to my workflow and my motivation. I can’t believe how much work I’ve lost, at least it’s not all gone.

I’ve been seeing quite a few server issues and corrupted places recently, Roblox really needs to step up their game because this is absolutely not okay. I’m still really annoyed about lost progress…

Please fix whatever’s causing this issue with place files, I know there’s probably a lot of other people also having problems.

4 Likes

Hopefully Roblox will figure out a way to give us access to our places again.

We are actively looking into this. I will follow up with you via private message

2 Likes

I’d like to add that I also had this issue with my game becoming corrupted with the same 2 errors. I had to revert to the last non-corrupted version which was luckily not too far back in my progress. The current solution that worked for me is to save the game locally prior to publishing and to disable team create.

It seems as if corruption errors have started happening a lot more frequently. I’ve seen an increased number of these types of posts. The only odd thing about your post is that you said that you saved your game normally and yet it still got corrupted. I wish you luck in restoring your game.

1 Like

Thanks for reporting this, we put out a wider notice:

10 Likes