Every time I try to publish my game all it says: "Publish Failed"

I am trying to publish changes made to my game, every time I try to publish it says: “publish failed.”, even though I have a good connection.

I tried restarting the studio, and PC still doesn’t work, I tried to publish other games and it works just not this game.

7 Likes

If I were you I would try downloading the game and publishing the file to Roblox as your game.

There are many tutorials in YouTube on how to fix this issue, I would suggest seeing those tutorials.

I am having the same issue with my game now. Hopefully its just a connection issue with Roblox!

1 Like

Search the issue in YouTube and you should find results.

Try rebooting your PC or Reinstalling Roblox Studio or You can reset internet options in internet explorer so all your internet settings which create issues are reset back to factory settings.

I tried, A lot It’s been 6 days and it doesn’t work still, I can publish any other game but not this one, I don’t know why, Game size is just 20Mb

1 Like

I watched them all, tried the hosts files thing, none of them worked for me.

2 Likes

I did all of these several times, I can publish any other game with no issues but not this game, and it’s size is just 20Mb.

20 mb is quite big for a roblox place I think

What can I do to reduce the size?
here’s the game link btw:

I am just trying to add simple changes and this happened.

  • Try looking for scripts that are not useful and delete them
  • Try and see if you can find “while true do” loops. These can cause a lot of lag to your game if you don’t add a wait at the end of the loop. It can be wait(0.1).
  • See and scan for viruses that could be lagging you game.
  • Last option, maybe you don’t have enough internet to publish the game. It can be a computer problem.

I already got rid of all useless scripts, meshes, unions and models before, the game is lag free now as it went from 48Mb to 20Mb and I don’t think I can remove anymore, and about my internet’s speed about 70-80Mbps, I am just to do a few changes not even adding some models or scripts and all of a sudden it doesn’t let me.

Wait so you reduced part count.

can you try uploading it to a group or Uploading it from a diffrent accunt

1 Like

Perhaps the game itself (not game’s content) is an issue. Here are two things to try:

  1. Try publishing your game as something else (only to see results)
  2. Make a new game and manually copy everything from your game to the new game and then publish the new game as your game.

I just did and, Publish failed.
Seems like the problem is from the game itself, but what could it be?

I did, Publish failed too.
I created a bank baseplate and published it to the main game and it worked

Copying everything from your game to the baseplate game and then publishing the baseplate game as your main game might work.

What about terrain? -------------