Extremely Blocky Terrain Heightmap Fix

So far, all of my heightmap imports have been exporting with extremely blocky looks as shown in the pictures below:

It would be extremely time consuming and tedious for me to smooth out all this terrain. Is there a way to prevent this, or is this entirely a bug?


Don’t quote me on this but I believe this is how heightmaps usually are, I recently tried creating a large one myself a few days ago and found the same issue to be present. In my opinion the next best thing to do would be to go through with manual tools and smooth it out, it is tedious but it’s better than making it from scratch.


Well I’m gonna have fun. I just created a 32k x 32k terrain map that is entirely composed of canyons and mountains, so smoothing it all out would be taking me months to complete.


Could this possibly be a problem with the resolution of the heightmap that you used to generate this terrain? Sometimes blocky terrain could be a result of Roblox’s terrain voxels being buggy but this seems too large to be that. You may just be generating too large of terrain off of a heightmap that is just too low quality.

Just read your post again, your heightmap is likely too low resolution to be able to smoothly generate a 32000x32000 map. Try to find a way to increase the resolution of the heightmap and try to generate again and I believe it should be smoother. Besides that I don’t think it is a bug.

I’ve used and split a 4k resolution map, I don’t think resolution is the problem.

What did you use to create the heightmap? Is it off of google or have you made it by hand in something like world machine?

I used the paid version of Gaea, which allowed me to create 4k resolution maps

If you import a smaller version of the map does it have the same effects?

It is possible it may just be feature/studio limitations. Such high volumes of terrain can cause high stress on the program and it may not function as intended. So now I think it would be either a bug or limitation imposed by either the terrain feature or studio in itself. I’ll continue to think of what may be the problem.

1 Like

Yes, it does. That’s why I tried to split the map but got no improvements

1 Like

Have you considered maybe its the software you’re using?

Have you tried using World Machine and seeing if it has the same effect?

Yeah, I’ll check that software out and see if there’s anything

1 Like

Have you tried replacing the material with another material to see if that fills in the holes, then switching it back ?

If you lower the y height does that change anything?

If you zoom into your source height map images to where the hole appear , is the texture clean with no spots ? (Or i guess you also need to look at the color map also … )

Does that happen with every h map u do ?

Also if you want to share a smaller height map / color map i can see if the issue happens and also play around with it

Here, you can play with the heightmap if you’d like

The image quality might be reduced

How are you having it determine the material it generates ?

Maybe improving the range could make it less blocky. Could you try adjusting the brightness and contrast so that the brightest pixel is 255 and the darkest is 0?

Do you know how to do that in GIMP or what ap are you using to do the range setting?

I just have it generate snow. Don’t necessarily think that the material is the issue.