Extremely high economy ratelimits

Recently Roblox released the ability for UGC creators to upload bundles for free. A few days ago, I bought all the free bundles and dynamic heads one after another. I didn’t use a bot - it was just me opening each item in a new tab and buying them. However, near the end of this, the purchases started failing. I would click buy, click confirm, and the modal would disappear but the item was never purchased. I checked the dev console and the economy.roblox.com purchase endpoint was returning 403 Forbidden with this response:

    "errors": [
            "code": 27,
            "message": "Too many requests within the time frame.",
            "userFacingMessage": "Something went wrong"

I didn’t think much of it and just assumed I bought the items too quickly — although I was confused as to why it returned 403 Forbidden when ratelimiting issues usually return 429 Too Many Requests. I waited a few hours then tried again, but the purchases were still failing, so I turned on a VPN to buy the rest.

The VPN allowed me to buy only two items before the ratelimit kicked in again. I turned off the VPN and was able to buy two more items with my normal IP. There seems to be a 3-minute cooldown before being able to purchase 2 more items on the same IP. I hadn’t heard of this before but just left it as-is for a couple days.

However, after multiple days of not buying anything, I still kept getting the same error every 2 purchases I made, for about 3 minutes.

I’ve tried resetting my ROBLOSECURITY, clearing cache, playing from other devices & other accounts, but it still continues to happen. I don’t understand how it knows it’s me on a different IP with a different account.

What’s interesting is this doesn’t appear to affect purchasing items that cost Robux. I was able to purchase an unlimited number of non-free items, but only 2 free items every 3 minutes. This doesn’t really affect me as I’m not purchasing items (free or non-free) very often, but it’s still happening.

Is this happening to anyone else? Does anyone know how to fix this?

(This was originally posted in another category)


Same, I also encountered this ratelimits, see this post for more.


I am definitely experiencing this problem and hope it will get fixed soon.

1 Like