Failed to load sound rbxassetid:// ID: Unable to download sound data

This is because people can just copy the asset ID and use the audio whether they bought it or not.

So as of now unless you have been given permission OR you set the option of “sharing” to public, you can’t use it

(But obviously the sharing option has not been enabled yet and we still have no clue when roblox will allow us to share publicly)

It’s interesting to note that I’m getting errors on audio that I have uploaded, that I own the copyrights to. Which leads me to believe that they are having some sort of network/server problem.

Did you grant permissions of your audio to your game?

Usually when publishing a game it now shows a popup screen which lets you choose whether audio will work or not

Yes. Most of the time it works, but sometimes, I get an error when it loads.

yo subi mi primer musica que quiero poner en mi juego pero me sale Failed to load sound rbxassetid://11194847063: Unable to download sound data
como saber si esa cancion tiene copyright?

i am having the same issue here :eyes::

is there a way to fix this now?


Same here, and i still havent found a way to fix it


Yep! it happened to me as well, but not only with sounds but with my Content Provider so now my games and studio are having trouble loading, this started for me a week ago and I’m still trying to find a way to fix it… I’ve tried to everything such as clearing my http folder for Roblox and/or wiping Roblox and all it’s files off of my pc.

1 Like

A fix to that would be having your sounds in a folder (in replicated storage for example) and cloning these sounds where you want them to play, then playing them (or simply having the sounds where you want them to be and making them play).
You basically have the sounds already loaded if you do that instead of instancing the sounds in a script.
And having those sounds be made by you and approved by roblox obviously

1 Like

2 reasons why this is happening:

  1. you are using an outdated version of studio deleting and uninstalling should fix it

  2. the sound id was banned/taken down due to copywrite, if u made the songs/sounds yourself then check to see if u can view them. i had a similar issue where i hired a sound designer to add music to my game and they used copywritten music, about 2 weeks later all the songs were banned and my output just spammed “unable to load sound data” to fix just delete the sound id’s and start over


i would recommend just making the audio yourself


yes, i use gifs. its not irrelevant its funni, LAUGH! LAUGH I SAY!

1 Like

I wrote a script to find and fix these when all other methods fail.
You just replace the asset IDs with yours and can run it right inside studio.
It outputs the full file path to that asset ID.
They made a “ViewSounds” plugin but it still doesn’t find them all.

1 Like

This started occuring today. Best to revive this topic.

1 Like

it was a problem for me for months

1 Like

I’ve also been having this problem for months

1 Like

I’d like to bump this because I have the same problem. I have two versions of the same game. There is one inside a group I own and while it works fine in the original. I have no way approve the sounds in the new game.

This is a pretty annoying problem. Audio discovery does not recognize any sounds I added to the place.

1 Like

I have the same problem here. My music I added to the workspace works fine, but when I try to change a song ID using a script and play it, I get the error no matter what ID I put in.

1 Like

its broken for me as well, i thought my audios got imediatly moderated

1 Like

Looks like it’s happening every November haha :rofl:, got the same error even when using a new baseplate. Whenever I “View in browser” the audio works just fine. Not sure what’s going on though.

I just kept on putting the audio ID and it worked (took me like 3 tries maybe?)

1 Like