Failed to start network server, port: 53640, error: SOCKET_PORT_PRIVILEGED

Reproduction Steps
The bug (for me) first appeared on 11/26/2021 at about 10:00 AM EDT.
I disabled all beta features (but at the time the bug happened the Pivot Editor and Parallel Lua were enabled).
I reinstalled studio and removed all plugins, but this didn’t fix it. Neither did the disabling of beta features (and I restarted studio after I disabled the beta features).
This happens in team create and locally.

System information

  • CPU AMD Ryzen 9 5900x
  • GPU NVIDIA GeForce RTX 3080
  • OS Windows 10 Home version 10.0.19041 Build 19041

Roblox version 0.504.0.5040410.

Possibly related: Studio local server fails to start with error "SOCKET_FAILED_TEST_SEND" in output log

Expected Behavior
I should be able to to create a local test server.

Actual Behavior
I get the error:

Screenshot of the error

Test in a live server.

Issue Area: Studio
Issue Type: Other
Impact: Moderate
Frequency: Constantly
Date First Experienced: 2021-11-26 10:11:00 (-05:00)
Date Last Experienced: 2021-11-30 00:11:00 (-05:00)


Have you checked that nothing on your computer is using port 53640? This bug has been reported before so I’m going to ask you to just run this in your command prompt to validate that


Look for something around the lines of :53640. If thats too complex you can also just ping localhost:53640

Thank you for the reply!

First, how did you find out it was reported before? I searched on both Google and the DevForum and found nothing, :(.

Second, it’s all clear. Nothing seems to be using port 53640.

I searched up “port 53640” and found this Test Servers Are Failing To Connect

Current tips in that are to check there aren’t any Studio processes still open, however it would’ve made the port come up in netstat

Oh interesting. How did you know that error ID 5 is the same as the error I’m currently having? Thank you for sharing, by the way!

And oh well, hopefully staff or someone else who encountered and fixed this issue is able to help out, :D.

To me it sounds like an error with the Windows Firewall Request that pops up whenever Roblox tries to create a test server. Try going to the search bar and typing in Allow an app through Windows Firewall, and open the app. Scroll down to where it has Roblox listed and just enable everything with Roblox in the name.

Thank you!

So, I am not sure what fixed this:

Allowing all of Roblox apps to run in the fire wall, restarting my PC, or both. Because when I tried the former it didn’t work, but I restarted my PC and then it worked. I however was prompted by Roblox to be allowed by the firewall. So maybe it was something preventing it. I don’t know.

Basically: if you’re encountering the same error try restarting your PC (the tried and true method I should’ve attempted from the get-go). If this doesn’t work do as defaultyboii1324 said and allow all those apps through the firewall and then restart your computer.

1 Like

Windows Firewall is your problem.

Port 53640 was being used previously by malware so Microsoft decided to add it to the watch list, therefore not a thing can get past it.

Allow Roblox in your firewall settings then try again.

1 Like

Hi CeaselessQuokka,

Thanks for reporting this issue.
If you can share logs from that studio run we may be able to find a better solution for this problem.
you can find logs at “%localappdata%\Roblox\logs” (for windows machine)


Hello alphavoyager:

Thank you for the reply! I zipped a few logs since I wasn’t exactly sure at what time I tested.

If you need anymore information, logs, or anything in between please let me know and I’d be more than happy to help, :). (38.1 KB)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.