Studio local server fails to start with error "SOCKET_FAILED_TEST_SEND" in output log

I’ve recently been encountering an issue where I am completely unable to use the local server functionality of studio to test my games. The output log will print the following:

and each client will be unable to connect, displaying the following error:

I have attempted restarting multiple times, disabling all of my plugins, and completely reinstalling studio but nothing has worked. I’ve also checked my firewall rules and attempted to manually allow the port that is listed on that error for all programs (I’m on Windows 10, version 20H2), this has not helped. Also attempted to check if any other programs have that port open, but there don’t appear to be any.

This error has been popping up for me consistently for over a month now but restarting routinely fixed it. Now it’s popping up 100% of the time and I am completely unable to use local servers in studio as a result despite everything I’ve tried.


Have you tried running the w10 troubleshooter and selecting network?
Do you get any other app with network problems?
Did you do a full uninstall powered down and back up and install fresh?

Is windows firewall (or whatever you use) blocking it? Would make sense if that was the problem, as well, its a local server. You get the point probably, just check.

I mentioned on my post that I checked my firewall and attempted to add a rule allowing the port that was shown in the error for all apps, but this didn’t fix the issue unfortunately (neither were there any entries related to this port at all before the one I added). I haven’t encountered any other network-related issues besides this, either.

I encountered a similar error that was solved by first running the Windows 10 Network Troubleshooter in network settings, and then going into Windows Defender and manually allowing RobloxStudio.exe to run (could also be RobloxStudioBeta.exe or RobloxStudioLauncher.exe).
Edit: Didn’t mean to reply to 4th post, sorry lol

1 Like

Hello, thanks for the report! Does this issue still occur on your side?


Yes, this is still happening for me. Unfortunately I don’t have any new information, I’ve checked for any applications using this port on my computer but it seems the port is not in use and isn’t being blocked by Windows Firewall or any AV/security software.

1 Like

This has just started occurring for me:image


This is happening to me and is stopping me from being able to properly test my game. Starting local servers was working fine, then when I went to start another one this error started happening. I’ve tried restarting studio but the error persists


Hello! Does this issue occur anymore for any of you?

I seem to have a similar issue. Apparently, a new Roblox version was released, and when attempting to update Roblox Studio to the newest version, I got this error, and I’m no longer able to open Studio due to the not working update.image

1 Like

Same here, every time I try to load into a older place/recent place it seems to not work, but it seems to work in new places such as the templates in studio.

i also got the same here there when uninstalling Roblox Studio and installing it

I’ve somehow fixed it by updating my Roblox Studio via the classic Create New Experience button. I attempted a full clean re-install previously, but it did not work. Though, after the clean re-install I clicked the button I mentioned before and it worked. Thought this information would be useful to you.

This is the button:

1 Like